Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1926609

Summary: python-sushy fails to build with Python 3.10: AttributeError: module 'collections' has no attribute 'MutableMapping'
Product: [Fedora] Fedora Reporter: Tomáš Hrnčiar <thrnciar>
Component: python-sushyAssignee: Alfredo Moralejo <amoralej>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: amoralej, dtantsur, jcapitao, mhroncok, openstack-sig, thrnciar
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-06-07 11:55:53 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1890881    

Description Tomáš Hrnčiar 2021-02-09 08:15:15 UTC
python-sushy fails to build with Python 3.10.0a5.

======================================================================
ERROR: sushy (unittest.loader._FailedTest)
----------------------------------------------------------------------
ImportError: Failed to import test module: sushy
Traceback (most recent call last):
  File "/usr/lib64/python3.10/unittest/loader.py", line 470, in _find_test_path
    package = self._get_module_from_name(name)
  File "/usr/lib64/python3.10/unittest/loader.py", line 377, in _get_module_from_name
    __import__(name)
  File "/builddir/build/BUILD/sushy-3.4.1/sushy/__init__.py", line 19, in <module>
    from sushy.main import Sushy
  File "/builddir/build/BUILD/sushy-3.4.1/sushy/main.py", line 60, in <module>
    class LazyRegistries(collections.MutableMapping):
AttributeError: module 'collections' has no attribute 'MutableMapping'

The deprecated aliases to Collections Abstract Base Classes were removed from the collections module.
https://docs.python.org/3.10/whatsnew/changelog.html#python-3-10-0-alpha-5
https://bugs.python.org/issue37324

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.10/fedora-rawhide-x86_64/01952494-python-sushy/

For all our attempts to build python-sushy with Python 3.10, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/package/python-sushy/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.10:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/

Let us know here if you have any questions.

Python 3.10 will be included in Fedora 35. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.10.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Ben Cotton 2021-02-09 16:08:28 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 34 development cycle.
Changing version to 34.

Comment 2 Joel Capitao 2021-02-16 14:19:27 UTC
A fix has been proposed upstream [1] and merged.

[1] https://review.opendev.org/c/openstack/sushy/+/774598

Comment 3 Miro Hrončok 2021-06-04 20:13:21 UTC
This is a mass-posted update. Sorry if it is not 100% accurate to this bugzilla.


The Python 3.10 rebuild is in progress in a Koji side tag. If you manage to fix the problem, please commit the fix in the rawhide branch, but don't build the package in regular rawhide.

You can either build the package in the side tag, with:

    $ fedpkg build --target=f35-python

Or you can the build and we will eventually build it for you.

Note that the rebuild is still in progress, so not all (build) dependencies of this package might be available right away.

Thanks.

See also https://fedoraproject.org/wiki/Changes/Python3.10

If you have general questions about the rebuild, please use this mailing list thread: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/G47SGOYIQLRDTWGOSLSWERZSSHXDEDH5/

Comment 4 Dmitry Tantsur 2021-06-07 11:55:53 UTC
This bug has been fixed in rawhide, the 3.10 rebuild fails because of a dependency:

DEBUG util.py:444:  Error: 
DEBUG util.py:444:   Problem: conflicting requests
DEBUG util.py:444:    - nothing provides python(abi) = 3.9 needed by python3-oslotest-4.4.1-3.fc34.noarch
DEBUG util.py:446:  (try to add '--skip-broken' to skip uninstallable packages)
DEBUG util.py:598:  Child return code was: 1