Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1928696

Summary: F35FailsToInstall: julia
Product: [Fedora] Fedora Reporter: Miro Hrončok <mhroncok>
Component: juliaAssignee: Milan Bouchet-Valat <nalimilan>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: chris, nalimilan
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-03-14 20:26:44 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1927313    

Description Miro Hrončok 2021-02-15 11:56:46 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok).

Your package (julia) Fails To Install in Fedora 35:

can't install julia:
  - nothing provides libgfortran.so.5 needed by julia-1.6.0-0.2.rc1.fc35.x86_64
  - nothing provides libgomp.so.1 needed by julia-1.6.0-0.2.rc1.fc35.x86_64
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.

P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors.

P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/rawhide-gating/multi-builds/

Thanks!

Comment 1 Miro Hrončok 2021-02-22 23:20:28 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 2 Milan Bouchet-Valat 2021-02-25 13:14:36 UTC
Failure has been introduced recently in Rawhide, everything works fine on F34. Probably a patch will be developed upstream to fix build with recent compiler versions.

Comment 3 Milan Bouchet-Valat 2021-02-25 13:42:14 UTC
glibc is 2.32 in F34 but 2.33 in Rawhide, and it was 2.32 last time Julia build succeeded in Rawhide. So that's probably the culprit. The error seems to be related to a problematic definition of MINSIGSTKSZ (which is supposed to live in signal.h):

 gcc -march=x86-64 -m64 -fasynchronous-unwind-tables -DSYSTEM_LIBUNWIND -DJULIA_HAS_IFUNC_SUPPORT=1 -DJULIA_NUM_THREADS=1 -DJL_USE_PERF_JITEVENTS -std=gnu99 -pipe -fPIC -fno-strict-aliasing -D_FILE_OFFSET_BITS=64 -DSYSTEM_LIBUNWIND -O2 -flto=auto -ffat-lto-objects -fexceptions -g -grecord-gcc-switches -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -fstack-protector-strong -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1 -m64 -mtune=generic -fasynchronous-unwind-tables -fstack-clash-protection -fcf-protection -Wold-style-definition -Wstrict-prototypes -Wc++-compat -O3 -ggdb2 -falign-functions -momit-leaf-frame-pointer -D_GNU_SOURCE -I. -I/builddir/build/BUILD/julia-1.6.0-rc1/src -I/builddir/build/BUILD/julia-1.6.0-rc1/src/flisp -I/builddir/build/BUILD/julia-1.6.0-rc1/src/support -I/builddir/build/BUILD/julia-1.6.0-rc1/build/usr/include -I/builddir/build/BUILD/julia-1.6.0-rc1/build/usr/include -DLIBRARY_EXPORTS -I/builddir/build/BUILD/julia-1.6.0-rc1/deps/valgrind -Wall -Wno-strict-aliasing -fno-omit-frame-pointer -fvisibility=hidden -fno-common -Wno-comment -Wpointer-arith -Wundef -Wno-unused-result -DJL_BUILD_ARCH='"x86_64"' -DJL_BUILD_UNAME='"Linux"' -I/builddir/build/BUILD/julia-1.6.0-rc1/build/usr/include -DLLVM_SHLIB "-DJL_SYSTEM_IMAGE_PATH=\"../lib/julia/sys.so\"" "-DJL_LIBJULIA_SONAME=\"libjulia.so.1\""       "-DJL_LIBJULIA_INTERNAL_SONAME=\"libjulia-internal.so.1\"" -DNDEBUG -DJL_NDEBUG -c /builddir/build/BUILD/julia-1.6.0-rc1/src/array.c -o array.o
In file included from /usr/include/signal.h:315,
                 from /builddir/build/BUILD/julia-1.6.0-rc1/src/task.c:31:
/builddir/build/BUILD/julia-1.6.0-rc1/src/task.c:78:29: error: missing binary operator before token "("
   78 | #if defined(MINSIGSTKSZ) && MINSIGSTKSZ > 131072

(According to https://gcc.gnu.org/bugzilla/show_bug.cgi?id=87351 the error message ir misleading.)

Comment 4 Milan Bouchet-Valat 2021-02-25 15:47:34 UTC
Filed upstream as https://github.com/JuliaLang/julia/issues/39822

Comment 5 Milan Bouchet-Valat 2021-03-14 20:26:44 UTC
I've pushed a workaround.