Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1933137

Summary: Warning: The unit file, source configuration file or drop-ins of httpd.service changed on disk. Run 'systemctl daemon-reload' to reload units
Product: [Fedora] Fedora Reporter: Harald Reindl <h.reindl>
Component: systemdAssignee: systemd-maint
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 33CC: fedoraproject, filbranden, flepied, kasong, lnykryn, msekleta, ssahani, s, systemd-maint, yuwatana, zbyszek, z
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: systemd-248~rc3-1.fc35 systemd-248~rc4-3.fc34 systemd-246.13-1.fc33 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-03-25 00:18:36 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Harald Reindl 2021-02-25 18:49:48 UTC
systemd-246.10-1.fc33.x86_64

besdies taht nobody changed anything except a vhost-config systemd has no business with:

[root@srv-rhsoft:~]$ systemctl reload httpd.service
Warning: The unit file, source configuration file or drop-ins of httpd.service changed on disk. Run 'systemctl daemon-reload' to reload units.

[root@srv-rhsoft:~]$ systemctl daemon-reload

[root@srv-rhsoft:~]$ systemctl reload httpd.service
Warning: The unit file, source configuration file or drop-ins of httpd.service changed on disk. Run 'systemctl daemon-reload' to reload units.

Comment 1 Harald Reindl 2021-02-25 20:02:09 UTC
i get that even after a fresh reboot for my httpd.service on all machines i upgraded yesterday from F32 to F33

[root@testserver:~]$ systemctl status httpd
● httpd.service - Apache Webserver
     Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled; vendor preset: disabled)
    Drop-In: /etc/systemd/system/httpd.service.d
             └─lockdown.conf, resource-control.conf
     Active: active (running) since Thu 2021-02-25 21:00:31 CET; 13s ago
   Main PID: 679 (httpd)
      Tasks: 6 (limit: 500)
     Memory: 25.1M (max: 2.0G)
        CPU: 2.033s
     CGroup: /system.slice/httpd.service
             ├─679 /usr/sbin/httpd -D testserver -D FOREGROUND
             ├─955 /usr/sbin/httpd -D testserver -D FOREGROUND
             ├─956 /usr/sbin/httpd -D testserver -D FOREGROUND
             ├─957 /usr/sbin/httpd -D testserver -D FOREGROUND
             ├─958 /usr/sbin/httpd -D testserver -D FOREGROUND
             └─959 /usr/sbin/httpd -D testserver -D FOREGROUND

Feb 25 21:00:31 testserver.rhsoft.net systemd[1]: Started Apache Webserver.
Warning: The unit file, source configuration file or drop-ins of httpd.service changed on disk. Run 'systemctl daemon-reload' to reload units.
[root@testserver:~]$

Comment 2 Zbigniew Jędrzejewski-Szmek 2021-03-02 17:45:53 UTC
https://github.com/systemd/systemd/issues/17730 sounds similar. There is some error in the way we calculate
"freshness" of drop-ins, but I never figured out the details.

Comment 3 Harald Reindl 2021-03-02 18:19:55 UTC
Hmmm

> Got the same problem. Touched my drop-in files in alphabetical order and it was gone

worked indeed on two machines talking about "drop-ins of httpd.service changed on disk" since the upgrade from F32 to F33

[root@srv-rhsoft:/etc/systemd/system/httpd.service.d]$ ls
insgesamt 8,0K
-rw-r--r-- 1 root root 402 2020-07-16 21:14 lockdown.conf
-rw-r--r-- 1 root root  23 2020-05-29 15:44 resource-control.conf
[root@srv-rhsoft:/etc/systemd/system/httpd.service.d]$ touch lockdown.conf
[root@srv-rhsoft:/etc/systemd/system/httpd.service.d]$ touch resource-control.conf
[root@srv-rhsoft:/etc/systemd/system/httpd.service.d]$ systemctl daemon-reload
[root@srv-rhsoft:/etc/systemd/system/httpd.service.d]$ systemctl status httpd.service 
● httpd.service - Apache Webserver
     Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled; vendor preset: disabled)
    Drop-In: /etc/systemd/system/httpd.service.d
             └─lockdown.conf, resource-control.conf
     Active: active (running) since Thu 2021-02-25 19:50:24 CET; 4 days ago
   Main PID: 559829 (httpd)
      Tasks: 11 (limit: 1024)
     Memory: 57.7M (max: 4.0G)
        CPU: 3min 56.894s
     CGroup: /system.slice/httpd.service
             ├─ 559829 /usr/sbin/httpd -D srv-rhsoft -D FOREGROUND
             ├─2221975 /usr/sbin/httpd -D srv-rhsoft -D FOREGROUND
             ├─2228124 /usr/sbin/httpd -D srv-rhsoft -D FOREGROUND
             ├─2235851 /usr/sbin/httpd -D srv-rhsoft -D FOREGROUND
             ├─2262336 /usr/sbin/httpd -D srv-rhsoft -D FOREGROUND
             ├─2262337 /usr/sbin/httpd -D srv-rhsoft -D FOREGROUND
             ├─2264898 /usr/sbin/httpd -D srv-rhsoft -D FOREGROUND
             ├─2264971 /usr/sbin/httpd -D srv-rhsoft -D FOREGROUND
             ├─2265038 /usr/sbin/httpd -D srv-rhsoft -D FOREGROUND
             ├─2265042 /usr/sbin/httpd -D srv-rhsoft -D FOREGROUND
             └─2265107 /usr/sbin/httpd -D srv-rhsoft -D FOREGROUND

Comment 4 Fedora Update System 2021-03-23 11:35:25 UTC
FEDORA-2021-1c1a870ceb has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2021-1c1a870ceb

Comment 5 Fedora Update System 2021-03-23 14:07:04 UTC
FEDORA-2021-ea92e5703f has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-ea92e5703f

Comment 6 Fedora Update System 2021-03-24 02:44:07 UTC
FEDORA-2021-ea92e5703f has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-ea92e5703f`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-ea92e5703f

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Fedora Update System 2021-03-24 11:57:45 UTC
FEDORA-2021-1c1a870ceb has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2021-1c1a870ceb

Comment 8 Fedora Update System 2021-03-25 00:18:36 UTC
FEDORA-2021-ea92e5703f has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 9 Fedora Update System 2021-03-25 01:31:40 UTC
FEDORA-2021-1c1a870ceb has been pushed to the Fedora 33 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-1c1a870ceb`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-1c1a870ceb

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Fedora Update System 2021-03-27 01:11:02 UTC
FEDORA-2021-1c1a870ceb has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.