Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1933328

Summary: Stacer does not work after being installed by dnf package manager
Product: [Fedora] Fedora EPEL Reporter: Henrique Mendonça Castelar Campos <henriquemendonacastelar>
Component: stacerAssignee: Artem <ego.cordatus>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: epel8CC: ego.cordatus
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: stacer-1.1.0-12.el8 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-03-15 00:16:30 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Henrique Mendonça Castelar Campos 2021-02-26 18:33:10 UTC
# Description of problem:

I was having problem with the package stacer (Stacer System Optimizer & Monitor) from Fedora EPEL.


After I installed stacer on my Red Hat Enterprise Linux 8, using this command: "sudo dnf install stacer", when I open stacer using Gnome Shell, nothing happens.

When I open the terminal and type the command: 'stacer' the following message appears: 

"
stacer: error while loading shared libraries: libQt5Charts.so.5: cannot open shared object file: No such file or directory
"

I searched the internet and found that the library libQt5Charts.so.5 was missing, and to fix it I had to install the package qt5-qtcharts.x86_64.
Reference:
https://github.com/oguzhaninan/Stacer/issues/187#issuecomment-374956787-permalink:~:text=%40caramello3469%20you%20can%20specify%20the%20architecture%20of%20the%20package%20that%20you%20prefer%20to%20install%2C%20try%20to%20install%20the%20package%20qt5%2Dqtcharts.x86_64%20to%20install%20the,latest%2064%2Dbit%20release%20of%20the%20package.,-1

So I did it typing the following command: "sudo dnf install qt5-qtcharts.x86_64"

So my problem was solved, but I believe that something is wrong with the package stacer because during its installation it should download and install its dependencies too. 

But when I type the following command: "sudo dnf deplist stacer" this is the output:

"
Updating Subscription Management repositories.
Last metadata expiration check: 3:15:30 ago on Fri 26 Feb 2021 11:36:05 -03.
package: stacer-1.1.0-9.el8.x86_64
  dependency: hicolor-icon-theme
   provider: hicolor-icon-theme-0.17-2.el8.noarch
  dependency: libGL.so.1()(64bit)
   provider: libglvnd-glx-1:1.2.0-6.el8.x86_64
  dependency: libQt5Charts.so.5()(64bit)
   provider: qt5-qtcharts-5.12.8-1.el8.x86_64
  dependency: libQt5Charts.so.5(Qt_5)(64bit)
   provider: qt5-qtcharts-5.12.8-1.el8.x86_64
  dependency: libQt5Concurrent.so.5()(64bit)
   provider: qt5-qtbase-5.12.5-6.el8.x86_64
  dependency: libQt5Core.so.5()(64bit)
   provider: qt5-qtbase-5.12.5-6.el8.x86_64
  dependency: libQt5Core.so.5(Qt_5)(64bit)
   provider: qt5-qtbase-5.12.5-6.el8.x86_64
  dependency: libQt5Core.so.5(Qt_5.12)(64bit)
   provider: qt5-qtbase-5.12.5-6.el8.x86_64
  dependency: libQt5Gui.so.5()(64bit)
   provider: qt5-qtbase-gui-5.12.5-6.el8.x86_64
  dependency: libQt5Gui.so.5(Qt_5)(64bit)
   provider: qt5-qtbase-gui-5.12.5-6.el8.x86_64
  dependency: libQt5Network.so.5()(64bit)
   provider: qt5-qtbase-5.12.5-6.el8.x86_64
  dependency: libQt5Network.so.5(Qt_5)(64bit)
   provider: qt5-qtbase-5.12.5-6.el8.x86_64
  dependency: libQt5Svg.so.5()(64bit)
   provider: qt5-qtsvg-5.12.5-1.el8.x86_64
  dependency: libQt5Widgets.so.5()(64bit)
   provider: qt5-qtbase-gui-5.12.5-6.el8.x86_64
  dependency: libQt5Widgets.so.5(Qt_5)(64bit)
   provider: qt5-qtbase-gui-5.12.5-6.el8.x86_64
  dependency: libc.so.6(GLIBC_2.14)(64bit)
   provider: glibc-2.28-127.el8_3.2.x86_64
  dependency: libgcc_s.so.1()(64bit)
   provider: libgcc-8.3.1-5.1.el8.x86_64
  dependency: libgcc_s.so.1(GCC_3.0)(64bit)
   provider: libgcc-8.3.1-5.1.el8.x86_64
  dependency: libgcc_s.so.1(GCC_3.3.1)(64bit)
   provider: libgcc-8.3.1-5.1.el8.x86_64
  dependency: libm.so.6()(64bit)
   provider: glibc-2.28-127.el8_3.2.x86_64
  dependency: libpthread.so.0()(64bit)
   provider: glibc-2.28-127.el8_3.2.x86_64
  dependency: libstdc++.so.6()(64bit)
   provider: libstdc++-8.3.1-5.1.el8.x86_64
  dependency: libstdc++.so.6(CXXABI_1.3)(64bit)
   provider: libstdc++-8.3.1-5.1.el8.x86_64
  dependency: libstdc++.so.6(CXXABI_1.3.1)(64bit)
   provider: libstdc++-8.3.1-5.1.el8.x86_64
  dependency: libstdc++.so.6(GLIBCXX_3.4)(64bit)
   provider: libstdc++-8.3.1-5.1.el8.x86_64
  dependency: rtld(GNU_HASH)
   provider: glibc-2.28-127.el8_3.2.x86_64
   provider: glibc-2.28-127.el8_3.2.i686
"

and the package qt5-qtcharts-5.12.8-1.el8.x86_64(libQt5Charts.so.5) was there. Then why stacer shown that error message?

Version-Release number of selected component (if applicable):

"
$ sudo dnf info stacer.x86_64
Name         : stacer
Version      : 1.1.0
Release      : 9.el8
Architecture : x86_64
Size         : 1.8 M
Source       : stacer-1.1.0-9.el8.src.rpm
Repository   : @System
From repo    : epel
Summary      : Linux system optimizer and monitoring
URL          : https://github.com/oguzhaninan/Stacer
License      : GPLv3+
Description  : Stacer is an open source system optimizer and application monitor
             : that helps users to manage entire system with different aspects,
             : its an all in one system utility.
"

"$ sudo dnf info qt5-qtcharts.x86_64
Updating Subscription Management repositories.
Last metadata expiration check: 0:25:38 ago on Fri 26 Feb 2021 15:05:24 -03.
Installed Packages
Name         : qt5-qtcharts
Version      : 5.12.8
Release      : 1.el8
Architecture : x86_64
Size         : 2.6 M
Source       : qt5-qtcharts-5.12.8-1.el8.src.rpm
Repository   : @System
From repo    : epel
Summary      : Qt5 - Charts component
URL          : http://www.qt.io
License      : GPLv3
Description  : Qt Charts module provides a set of easy to use chart components.
             : It uses the Qt Graphics View Framework, therefore charts can be
             : easily integrated to modern user interfaces. Qt Charts can be
             : used as QWidgets, QGraphicsWidget, or QML types. Users can easily
             : create impressive graphs by selecting one of the charts themes.
"

# Steps to Reproduce:

1. On a new installation of Red Hat Enterprise Linux 8, with Fedora Epel repository enabled type the following command:

"sudo dnf install stacer"

2. then, type this command:

"stacer"

3. then, (I hope) you will find that error message.

Comment 1 Fedora Update System 2021-02-27 06:53:08 UTC
FEDORA-EPEL-2021-9f9f9c3668 has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2021-9f9f9c3668

Comment 2 Artem 2021-02-27 07:13:10 UTC
Thanks for reporting. Submitted bugfix update to Testing.

Comment 3 Fedora Update System 2021-02-27 22:10:00 UTC
FEDORA-EPEL-2021-9f9f9c3668 has been pushed to the Fedora EPEL 8 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2021-9f9f9c3668

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 4 Fedora Update System 2021-03-15 00:16:30 UTC
FEDORA-EPEL-2021-9f9f9c3668 has been pushed to the Fedora EPEL 8 stable repository.
If problem still persists, please make note of it in this bug report.