Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1933529

Summary: The PHP memory limit is below the recommended value of 512MB
Product: [Fedora] Fedora Reporter: mwp.junk
Component: nextcloudAssignee: Christopher Engelhard <ce>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 37CC: avibrazil, ce, ichavero, james.hogarth, lovenemesis
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: nextcloud-19.0.12-1.fc33 nextcloud-nextcloud_19-3320210630133545.601d93de nextcloud-nextcloud_20-3320210630133442.601d93de nextcloud-nextcloud_stable-3320210630133028.601d93de nextcloud-nextcloud_19-3420210630133545.058368ca nextcloud-20.0.10-1.fc34 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2023-10-12 01:44:57 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description mwp.junk 2021-03-01 00:32:08 UTC
Steps to Reproduce:
1. install nextcloud
2. goto Settings - Overview (like https://www.example.com/nextcloud/index.php/settings/admin/overview)
3. get errors

Actual results:
1. nextcloud complains with: "The PHP memory limit is below the recommended value of 512MB"

Expected results:
1. no error

Fix:

Add `php_value[memory_limit] = 512M` to /etc/php-fpm.d/nextcloud.conf or nextcloud-php-fpm.conf in the src repo:

php_value[session.save_handler] = files
php_value[session.save_path]    = /var/lib/php/session
php_value[soap.wsdl_cache_dir]  = /var/lib/php/wsdlcache
+php_value[memory_limit] = 512M
php_value[upload_max_filesize] = 10G
php_value[post_max_size] = 10G
env[HOSTNAME] = $HOSTNAME

Comment 1 Fedora Update System 2021-06-30 18:51:36 UTC
FEDORA-2021-afa7968aeb has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2021-afa7968aeb

Comment 2 Fedora Update System 2021-06-30 18:51:37 UTC
FEDORA-MODULAR-2021-e727d9327a has been submitted as an update to Fedora 33 Modular. https://bodhi.fedoraproject.org/updates/FEDORA-MODULAR-2021-e727d9327a

Comment 3 Fedora Update System 2021-06-30 18:51:38 UTC
FEDORA-MODULAR-2021-8478b0e630 has been submitted as an update to Fedora 34 Modular. https://bodhi.fedoraproject.org/updates/FEDORA-MODULAR-2021-8478b0e630

Comment 4 Fedora Update System 2021-06-30 18:51:39 UTC
FEDORA-EPEL-MODULAR-2021-67b2caafec has been submitted as an update to Fedora Epel 8 Modular. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-MODULAR-2021-67b2caafec

Comment 5 Fedora Update System 2021-06-30 18:54:27 UTC
FEDORA-MODULAR-2021-7ec13e1ed3 has been submitted as an update to Fedora 34 Modular. https://bodhi.fedoraproject.org/updates/FEDORA-MODULAR-2021-7ec13e1ed3

Comment 6 Fedora Update System 2021-06-30 18:54:28 UTC
FEDORA-MODULAR-2021-872921fbec has been submitted as an update to Fedora 33 Modular. https://bodhi.fedoraproject.org/updates/FEDORA-MODULAR-2021-872921fbec

Comment 7 Fedora Update System 2021-06-30 18:54:29 UTC
FEDORA-2021-eac0e52f88 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-eac0e52f88

Comment 8 Fedora Update System 2021-06-30 19:46:19 UTC
FEDORA-MODULAR-2021-c8ef31abe2 has been submitted as an update to Fedora 34 Modular. https://bodhi.fedoraproject.org/updates/FEDORA-MODULAR-2021-c8ef31abe2

Comment 9 Fedora Update System 2021-07-01 01:04:37 UTC
FEDORA-2021-afa7968aeb has been pushed to the Fedora 33 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-afa7968aeb`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-afa7968aeb

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Fedora Update System 2021-07-01 01:18:29 UTC
FEDORA-2021-eac0e52f88 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-eac0e52f88`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-eac0e52f88

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 11 Fedora Update System 2021-07-01 01:26:28 UTC
FEDORA-MODULAR-2021-e727d9327a has been pushed to the Fedora 33 Modular testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-MODULAR-2021-e727d9327a

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 12 Fedora Update System 2021-07-01 01:26:33 UTC
FEDORA-MODULAR-2021-872921fbec has been pushed to the Fedora 33 Modular testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-MODULAR-2021-872921fbec

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 13 Fedora Update System 2021-07-01 01:26:44 UTC
FEDORA-MODULAR-2021-ce1106e638 has been pushed to the Fedora 33 Modular testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-MODULAR-2021-ce1106e638

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 14 Fedora Update System 2021-07-01 01:27:15 UTC
FEDORA-MODULAR-2021-8478b0e630 has been pushed to the Fedora 34 Modular testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-MODULAR-2021-8478b0e630

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 15 Fedora Update System 2021-07-01 01:27:20 UTC
FEDORA-MODULAR-2021-7ec13e1ed3 has been pushed to the Fedora 34 Modular testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-MODULAR-2021-7ec13e1ed3

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 16 Fedora Update System 2021-07-01 01:27:31 UTC
FEDORA-MODULAR-2021-c8ef31abe2 has been pushed to the Fedora 34 Modular testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-MODULAR-2021-c8ef31abe2

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 17 Fedora Update System 2021-07-01 01:30:10 UTC
FEDORA-EPEL-MODULAR-2021-67b2caafec has been pushed to the Fedora Epel 8 Modular testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-MODULAR-2021-67b2caafec

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 18 Fedora Update System 2021-07-01 01:30:16 UTC
FEDORA-EPEL-MODULAR-2021-336bd8af0e has been pushed to the Fedora Epel 8 Modular testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-MODULAR-2021-336bd8af0e

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 19 Fedora Update System 2021-07-09 00:46:04 UTC
FEDORA-2021-afa7968aeb has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 20 Fedora Update System 2021-07-09 00:49:18 UTC
FEDORA-MODULAR-2021-e727d9327a has been pushed to the Fedora 33 Modular stable repository.
If problem still persists, please make note of it in this bug report.

Comment 21 Fedora Update System 2021-07-09 00:49:24 UTC
FEDORA-MODULAR-2021-872921fbec has been pushed to the Fedora 33 Modular stable repository.
If problem still persists, please make note of it in this bug report.

Comment 22 Fedora Update System 2021-07-09 00:50:09 UTC
FEDORA-MODULAR-2021-ce1106e638 has been pushed to the Fedora 33 Modular stable repository.
If problem still persists, please make note of it in this bug report.

Comment 23 Fedora Update System 2021-07-09 01:01:09 UTC
FEDORA-MODULAR-2021-8478b0e630 has been pushed to the Fedora 34 Modular stable repository.
If problem still persists, please make note of it in this bug report.

Comment 24 Fedora Update System 2021-07-09 01:01:15 UTC
FEDORA-MODULAR-2021-7ec13e1ed3 has been pushed to the Fedora 34 Modular stable repository.
If problem still persists, please make note of it in this bug report.

Comment 25 Fedora Update System 2021-07-09 01:01:27 UTC
FEDORA-MODULAR-2021-c8ef31abe2 has been pushed to the Fedora 34 Modular stable repository.
If problem still persists, please make note of it in this bug report.

Comment 26 Fedora Update System 2021-07-09 01:02:43 UTC
FEDORA-2021-eac0e52f88 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 27 Fedora Update System 2021-07-16 00:22:17 UTC
FEDORA-EPEL-MODULAR-2021-67b2caafec has been pushed to the Fedora Epel 8 Modular stable repository.
If problem still persists, please make note of it in this bug report.

Comment 28 Fedora Update System 2021-07-16 00:22:23 UTC
FEDORA-EPEL-MODULAR-2021-336bd8af0e has been pushed to the Fedora Epel 8 Modular stable repository.
If problem still persists, please make note of it in this bug report.

Comment 29 Avi Alkalay 2022-09-22 13:17:03 UTC
Current nextcloud package is 24.0.3.

I can see that /etc/php-fpm.d/nextcloud.conf contains "php_value[memory_limit] = 512M".
But makes no effect since nextcloud still complains PHP memory limit is below the recommended value of 512MB.

A phpinfo() under same server says that only /etc/php.d is being scanned for additional .ini files.
And it also shows 256MB for memory_limit.

I have php-fpm enabled and running and I can see php-fpm processes in the system.

Configurations put under /etc/php-fpm.d/ seems to make no effect.
Or Apache is not routing requests to /nextcloud URI to the php-fpm system.

Comment 30 Avi Alkalay 2022-09-22 13:43:45 UTC
I also noticed that /etc/php-fpm.d/nextcloud.conf declares several log files and folders that php-fpm should use.
But those are not being created or even used.

A simple `ps faxu | gre php` displays nextcloud-related processes.

Comment 31 Avi Alkalay 2022-09-23 09:20:48 UTC
The shipped nextcloud HTTPD configuration is not using PHP-FPM's dedicated process installed by next cloud package.

The config file /etc/httpd/conf.d/nextcloud-defaults.inc is lacking the <FilesMatch> directive as shown bellow:

<IfModule mod_fcgid.c>
    <IfModule mod_setenvif.c>
        <IfModule mod_headers.c>
            SetEnvIfNoCase ^Authorization$ "(.+)" XAUTHORIZATION=$1
            RequestHeader set XAuthorization %{XAUTHORIZATION}e env=XAUTHORIZATION
        </IfModule>
    </IfModule>
    <FilesMatch \.(php|phar)$>
        SetHandler "proxy:unix:/run/php-fpm/nextcloud.sock|fcgi://localhost"
    </FilesMatch>
</IfModule>

I'm already writing a patch to fix this and add other improvements and will commit it to https://src.fedoraproject.org/fork/aviram/rpms/nextcloud

Thank you

Comment 32 Avi Alkalay 2022-09-23 10:34:48 UTC
I shipped a fix for this and other updates on this PR: https://src.fedoraproject.org/rpms/nextcloud/pull-request/7

Comment 33 Ivan Chavero 2022-10-12 23:27:41 UTC
PR merged and cherry picked to the proper branches

Comment 34 Ivan Chavero 2022-10-12 23:28:44 UTC
This change is part of the current builds:
https://koji.fedoraproject.org/koji/packageinfo?packageID=23789

Comment 35 Tommy He 2022-10-26 02:23:36 UTC
(In reply to Ivan Chavero from comment #34)
> This change is part of the current builds:
> https://koji.fedoraproject.org/koji/packageinfo?packageID=23789

Would you please be a bit more specific on what current build addressed this issue?

I'm currently using nextcloud-24.0.5-1.fc36.noarch and nextcloud-httpd-24.0.5-1.fc36.noarch.
And the settings located in /etc/php-fpm.d/nextcloud.conf still doesn't take effect.

Thanks,

Comment 36 Tommy He 2022-11-24 02:31:01 UTC
The issue persists on a fresh installed Fedora 37 with build´╝Ü nextcloud-24.0.5-1.fc37.noarch

Comment 37 Fedora Update System 2023-10-03 20:55:30 UTC
FEDORA-2023-ed33f2d60a has been submitted as an update to Fedora 39. https://bodhi.fedoraproject.org/updates/FEDORA-2023-ed33f2d60a

Comment 38 Fedora Update System 2023-10-03 20:56:32 UTC
FEDORA-2023-815a43e875 has been submitted as an update to Fedora 38. https://bodhi.fedoraproject.org/updates/FEDORA-2023-815a43e875

Comment 39 Fedora Update System 2023-10-04 02:18:21 UTC
FEDORA-2023-ed33f2d60a has been pushed to the Fedora 39 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-ed33f2d60a`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-ed33f2d60a

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 40 Fedora Update System 2023-10-04 03:30:28 UTC
FEDORA-2023-815a43e875 has been pushed to the Fedora 38 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-815a43e875`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-815a43e875

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 41 Fedora Update System 2023-10-12 01:44:57 UTC
FEDORA-2023-815a43e875 has been pushed to the Fedora 38 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 42 Fedora Update System 2023-11-03 18:28:07 UTC
FEDORA-2023-ed33f2d60a has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.