Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1944428

Summary: "Fedora Linux" in /etc/os-release
Product: [Fedora] Fedora Reporter: Ben Cotton <bcotton>
Component: Changes TrackingAssignee: Matthew Miller <mattdm>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 35CC: bcotton, mattdm, sgallagh, vponcova
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-11-02 16:03:44 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1894270    

Description Ben Cotton 2021-03-29 22:25:15 UTC
This is a tracking bug for Change: "Fedora Linux" in /etc/os-release
For more details, see: https://fedoraproject.org/wiki/Changes/Fedora_Linux_in_os-release

"Fedora" is the name of our project. Our general-purpose Linux distribution is "Fedora Linux". Let's refer to it that way in the OS itself.

Comment 2 Ben Cotton 2021-08-10 12:33:03 UTC
Today is the "Code complete (testable)" deadline in the Fedora Linux 35 release schedule:
https://fedorapeople.org/groups/schedule/f-35/f-35-key-tasks.html

If this Change is complete enough to be tested, please indicate this by setting this bug to the MODIFIED status. (If it is 100% complete, you can set it to ON_QA).

If you wish to defer this Change to Fedora Linux 36, please needinfo bcotton.

Comment 3 Stephen Gallagher 2021-08-11 14:31:21 UTC
This has been in effect since fedora-release-35-0.9 (released April 30th).

Comment 4 Artem S. Tashkinov 2021-09-02 11:25:39 UTC
I'm curious what if Fedora suddenly adopts GNU/HURD, FreeBSD or any other open source kernel, e.g. even Google's Zircon.

Will "Linux" in its name still be appropriate?

Comment 5 Stephen Gallagher 2021-09-02 13:29:53 UTC
(In reply to Artem S. Tashkinov from comment #4)
> I'm curious what if Fedora suddenly adopts GNU/HURD, FreeBSD or any other
> open source kernel, e.g. even Google's Zircon.
> 
> Will "Linux" in its name still be appropriate?


That is incredibly unlikely, but if it should happen in the future this change can be re-evaluated.

Comment 6 Ben Cotton 2021-11-02 16:03:44 UTC
F35 was released today. Closing the trackers.