Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1944533

Summary: Mayavi fails to build with Python 3.10: AttributeError: module 'collections' has no attribute 'Callable'
Product: [Fedora] Fedora Reporter: Tomáš Hrnčiar <thrnciar>
Component: MayaviAssignee: Orion Poplawski <orion>
Status: CLOSED WORKSFORME QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: chedi.toueiti, mhroncok, orion, rakesh.pandit, thrnciar
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-08-03 10:44:03 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1890881, 1927309, 1927313, 1977507    

Description Tomáš Hrnčiar 2021-03-30 06:41:55 UTC
Mayavi fails to build with Python 3.10.0a6.

Building TVTK classes... 

Failed on ObjectBase
(#2 of 10 nodes, #62 of 111 subnodes)

Traceback (most recent call last):
  File "/builddir/build/BUILD/mayavi-4.7.2/setup.py", line 411, in <module>
    setup(
  File "/usr/lib64/python3.10/site-packages/numpy/distutils/core.py", line 169, in setup
    return old_setup(**new_attr)
  File "/usr/lib/python3.10/site-packages/setuptools/__init__.py", line 153, in setup
    return distutils.core.setup(**attrs)
  File "/usr/lib64/python3.10/distutils/core.py", line 148, in setup
    dist.run_commands()
  File "/usr/lib64/python3.10/distutils/dist.py", line 966, in run_commands
    self.run_command(cmd)
  File "/usr/lib64/python3.10/distutils/dist.py", line 985, in run_command
    cmd_obj.run()
  File "/builddir/build/BUILD/mayavi-4.7.2/setup.py", line 268, in run
    build_tvtk_classes_zip()
  File "/builddir/build/BUILD/mayavi-4.7.2/setup.py", line 254, in build_tvtk_classes_zip
    gen_tvtk_classes_zip()
  File "tvtk/setup.py", line 99, in gen_tvtk_classes_zip
    # become invalid.
  File "/builddir/build/BUILD/mayavi-4.7.2/tvtk/code_gen.py", line 134, in generate_code
    self._write_wrapper_class(node, tvtk_name)
  File "/builddir/build/BUILD/mayavi-4.7.2/tvtk/code_gen.py", line 229, in _write_wrapper_class
    self.wrap_gen.generate_code(node, out)
  File "/builddir/build/BUILD/mayavi-4.7.2/tvtk/wrapper_gen.py", line 256, in generate_code
    self._gen_methods(node, out)
  File "/builddir/build/BUILD/mayavi-4.7.2/tvtk/wrapper_gen.py", line 355, in _gen_methods
    self.parser.parse(klass)
  File "/builddir/build/BUILD/mayavi-4.7.2/tvtk/vtk_parser.py", line 156, in parse
    self._organize_methods(klass, methods)
  File "/builddir/build/BUILD/mayavi-4.7.2/tvtk/vtk_parser.py", line 476, in _organize_methods
    self.other_meths = [
  File "/builddir/build/BUILD/mayavi-4.7.2/tvtk/vtk_parser.py", line 478, in <listcomp>
    if isinstance(getattr(klass, x), collections.Callable)
AttributeError: module 'collections' has no attribute 'Callable'

bpo-37324: Remove deprecated aliases to Collections Abstract Base Classes
from the collections module.

https://docs.python.org/3.10/whatsnew/changelog.html#python-3-10-0-alpha-6

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.10/fedora-rawhide-x86_64/02108086-Mayavi/

For all our attempts to build Mayavi with Python 3.10, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/package/Mayavi/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.10:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/

Let us know here if you have any questions.

Python 3.10 will be included in Fedora 35. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.10.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Miro Hrončok 2021-06-04 20:14:23 UTC
This is a mass-posted update. Sorry if it is not 100% accurate to this bugzilla.


The Python 3.10 rebuild is in progress in a Koji side tag. If you manage to fix the problem, please commit the fix in the rawhide branch, but don't build the package in regular rawhide.

You can either build the package in the side tag, with:

    $ fedpkg build --target=f35-python

Or you can the build and we will eventually build it for you.

Note that the rebuild is still in progress, so not all (build) dependencies of this package might be available right away.

Thanks.

See also https://fedoraproject.org/wiki/Changes/Python3.10

If you have general questions about the rebuild, please use this mailing list thread: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/G47SGOYIQLRDTWGOSLSWERZSSHXDEDH5/

Comment 2 Miro Hrončok 2021-06-07 22:59:02 UTC
The f35-python side tag has been merged to Rawhide. From now on, build as you would normally build.

Comment 3 Miro Hrončok 2021-06-08 11:17:31 UTC
*** Bug 1968767 has been marked as a duplicate of this bug. ***

Comment 4 Miro Hrončok 2021-06-15 20:26:30 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 5 Miro Hrončok 2021-07-26 09:14:09 UTC
The PR is https://src.fedoraproject.org/rpms/Mayavi/pull-request/2

However, it now conflicts due to the mass rebuild commit.

Comment 6 Miro Hrončok 2021-08-03 10:44:03 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok).

All subpackages of a package against which this bug was filled are now installable or removed from Fedora 35.

Thanks for taking care of it!