Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1948573

Summary: python-pynwb: FTBFS in Fedora rawhide
Product: [Fedora] Fedora Reporter: Ankur Sinha (FranciscoD) <sanjay.ankur>
Component: python-pynwbAssignee: Ankur Sinha (FranciscoD) <sanjay.ankur>
Status: CLOSED NEXTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 35CC: bazanluis20, neuro-sig, releng
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
URL: https://koschei.fedoraproject.org/package/python-pynwb
Whiteboard:
Fixed In Version: python-pynwb-2.0.0-1.fc35 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-08-17 08:09:51 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 1948404    
Bug Blocks: 1927309, 1931183, 1992484    

Description Ankur Sinha (FranciscoD) 2021-04-12 13:39:30 UTC
Description of problem:
Package python-pynwb fails to build from source in Fedora rawhide.

Version-Release number of selected component (if applicable):
1.4.0-2.fc34

Steps to Reproduce:
koji build --scratch f35 python-pynwb-1.4.0-2.fc34.src.rpm

Additional info:
This package is tracked by Koschei. See:
https://koschei.fedoraproject.org/package/python-pynwb

Comment 1 Ankur Sinha (FranciscoD) 2021-04-12 13:40:50 UTC
This is because 1.4.0 does not support hdmf 2.4.0. Upstream has added support for the new hdmf version now, but not made a release. So we can carry a snapshot for the time being.

Comment 2 Ankur Sinha (FranciscoD) 2021-08-02 13:30:05 UTC
*** Bug 1987885 has been marked as a duplicate of this bug. ***

Comment 3 Ben Cotton 2021-08-10 12:58:43 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 35 development cycle.
Changing version to 35.