Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1954209

Summary: F34FailsToInstall: python3-scrapy
Product: [Fedora] Fedora Reporter: Miro Hrončok <mhroncok>
Component: python-scrapyAssignee: Eduardo Echeverria <echevemaster>
Status: CLOSED WORKSFORME QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 34CC: echevemaster, mike
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-05-25 19:30:07 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1868279    

Description Miro Hrončok 2021-04-27 18:18:32 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok).

Your package (python-scrapy) Fails To Install in Fedora 34:

can't install python3-scrapy:
  - nothing provides python3.9dist(itemadapter) >= 0.1 needed by python3-scrapy-2.4.1-1.fc34.noarch
  - nothing provides python3.9dist(itemloaders) >= 1.0.1 needed by python3-scrapy-2.4.1-1.fc34.noarch
  - nothing provides python3.9dist(protego) >= 0.1.15 needed by python3-scrapy-2.4.1-1.fc34.noarch
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.

P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors.

P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Eduardo Echeverria 2021-04-29 16:22:38 UTC
I'm waiting for Kevin Fenzi to update python-jmespath, which is a dependency of the mentioned missed packages (already in rawhide)

Comment 2 Eduardo Echeverria 2021-05-02 17:02:37 UTC
Were sent the updates for update python-jmespath today, I'll wait for them be send pushed to stable and then build the needed dependencies to build python-scrapy on these branches.
Appreciate your patience

https://bodhi.fedoraproject.org/updates/FEDORA-2021-a28ab3e6ee
https://bodhi.fedoraproject.org/updates/FEDORA-2021-034497eedd

Comment 3 Eduardo Echeverria 2021-05-16 17:08:58 UTC
jmespath was pushed to stable branches, I asked scm request for dependencies, once admins create them I'll build the dependencies to build this one

Comment 4 Miro Hrončok 2021-05-25 19:30:07 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok).

All subpackages of a package against which this bug was filled are now installable or removed from Fedora 34.

Thanks for taking care of it!

Comment 5 Mike Gerber 2021-05-27 14:00:11 UTC
python3-scrapy still fails to update for me on F34:

 Problem: cannot install the best update candidate for package python3-scrapy-1.5.1-10.fc34.noarch
  - nothing provides python3.9dist(itemadapter) >= 0.1 needed by python3-scrapy-2.4.1-1.fc34.noarch
  - nothing provides python3.9dist(itemloaders) >= 1.0.1 needed by python3-scrapy-2.4.1-1.fc34.noarch
  - nothing provides python3.9dist(protego) >= 0.1.15 needed by python3-scrapy-2.4.1-1.fc34.noarch