Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1962238

Summary: python-django-auth-ldap fails to build with Python 3.10: AssertionError: 5 != 1
Product: [Fedora] Fedora Reporter: Tomáš Hrnčiar <thrnciar>
Component: python-django-auth-ldapAssignee: Miro Hrončok <mhroncok>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 35CC: droidbittin, igor.raits, lruzicka, mhroncok, thrnciar
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: AcceptedFreezeException
Fixed In Version: python-django-auth-ldap-2.4.0-2.fc35 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-09-16 23:55:51 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1890881, 1891954, 1927309, 1927313, 1992484, 1992487    

Description Tomáš Hrnčiar 2021-05-19 14:54:27 UTC
python-django-auth-ldap fails to build with Python 3.10.0b1.

======================================================================
FAIL: test_deprecated_cache_groups (tests.tests.LDAPTest)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/builddir/build/BUILD/django-auth-ldap-2.2.0/tests/tests.py", line 1578, in test_deprecated_cache_groups
    self.assertEqual(len(w), 1)
AssertionError: 5 != 1

======================================================================
FAIL: test_deprecated_callable_server_uri (tests.tests.LDAPTest)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/builddir/build/BUILD/django-auth-ldap-2.2.0/tests/tests.py", line 195, in test_deprecated_callable_server_uri
    self.assertEqual(len(w), 1)
AssertionError: 5 != 1

----------------------------------------------------------------------
Ran 90 tests in 2.172s

FAILED (failures=2)

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.10/fedora-rawhide-x86_64/02197727-python-django-auth-ldap/

For all our attempts to build python-django-auth-ldap with Python 3.10, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/package/python-django-auth-ldap/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.10:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/

Let us know here if you have any questions.

Python 3.10 will be included in Fedora 35. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.10.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Miro Hrončok 2021-06-04 20:16:03 UTC
This is a mass-posted update. Sorry if it is not 100% accurate to this bugzilla.


The Python 3.10 rebuild is in progress in a Koji side tag. If you manage to fix the problem, please commit the fix in the rawhide branch, but don't build the package in regular rawhide.

You can either build the package in the side tag, with:

    $ fedpkg build --target=f35-python

Or you can the build and we will eventually build it for you.

Note that the rebuild is still in progress, so not all (build) dependencies of this package might be available right away.

Thanks.

See also https://fedoraproject.org/wiki/Changes/Python3.10

If you have general questions about the rebuild, please use this mailing list thread: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/G47SGOYIQLRDTWGOSLSWERZSSHXDEDH5/

Comment 2 Miro Hrončok 2021-06-07 23:00:22 UTC
The f35-python side tag has been merged to Rawhide. From now on, build as you would normally build.

Comment 3 Miro Hrončok 2021-06-08 11:24:09 UTC
*** Bug 1968956 has been marked as a duplicate of this bug. ***

Comment 4 Miro Hrončok 2021-06-15 20:28:17 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 5 Miro Hrončok 2021-07-07 11:38:14 UTC
Hello,

This is the second reminder (step 4 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 6 Fedora Release Engineering 2021-07-11 04:22:53 UTC
Dear Maintainer,

your package has an open Fails To Build From Source bug for Fedora 35.
Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. If you have already fixed this issue, please close this Bugzilla report.

Following the policy for such packages [2], your package will be orphaned if
this bug remains in NEW state more than 8 weeks (not sooner than 2021-07-14).

A week before the mass branching of Fedora 36 according to the schedule [3],
any packages not successfully rebuilt at least on Fedora 34 will be
retired regardless of the status of this bug.

[1] https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedorapeople.org/groups/schedule/f-36/f-36-key-tasks.html

Comment 7 Ben Cotton 2021-08-10 13:02:54 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 35 development cycle.
Changing version to 35.

Comment 8 Miro Hrončok 2021-08-23 11:28:33 UTC
Igor, what is happening here? have you reported this upstream, are you working on a fix?

Comment 9 Miro Hrončok 2021-09-02 16:05:16 UTC
FWIW it just seems like the tests get more deprecation warnings than expected, should be safe to skip those.

Comment 10 Miro Hrončok 2021-09-13 12:03:27 UTC
I've fixed it in https://src.fedoraproject.org/rpms/python-django-auth-ldap/pull-request/1

Comment 11 Fedora Update System 2021-09-13 12:37:59 UTC
FEDORA-2021-6cdb21251c has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-6cdb21251c

Comment 12 Fedora Update System 2021-09-13 16:15:37 UTC
FEDORA-2021-6cdb21251c has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-6cdb21251c`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-6cdb21251c

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 13 Luna Jernberg 2021-09-13 16:17:33 UTC
We agreed in todays Beta Blocker meeting to FE this

proposed #agreed 1962238 - The decision to classify this bug as an "AcceptedFreezeException (Beta)" was made as it is a noticeable issue that cannot be fixed with an update.

Comment 14 Fedora Update System 2021-09-16 23:55:51 UTC
FEDORA-2021-6cdb21251c has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.