Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1964630

Summary: F35FailsToInstall: eclipse-jdt, eclipse-pde, eclipse-platform
Product: [Fedora] Fedora Reporter: Miro Hrončok <mhroncok>
Component: eclipseAssignee: Orphan Owner <extras-orphan>
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 35CC: akurtako, andjrobins, atu, awilliam, dbhole, didiksupriadi41, ebaron, eclipse-sig, jerboaa, jjohnstn, lef, mat.booth, rgrunber, sergio
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-08-18 08:28:15 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 1987435    
Bug Blocks: 1927313, 1992487    
Attachments:
Description Flags
reults of retire of eclipse none

Description Miro Hrončok 2021-05-25 19:29:02 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok).

Your package (eclipse) Fails To Install in Fedora 35:

can't install eclipse-jdt:
  - nothing provides osgi(org.hamcrest.core) needed by eclipse-jdt-1:4.19-5.fc35.noarch
  
can't install eclipse-pde:
  - nothing provides osgi(org.objectweb.asm) needed by eclipse-pde-1:4.19-5.fc35.x86_64
  - nothing provides osgi(org.objectweb.asm.tree) needed by eclipse-pde-1:4.19-5.fc35.x86_64
  
can't install eclipse-platform:
  - nothing provides glassfish-annotation-api needed by eclipse-platform-1:4.19-5.fc35.x86_64
  - nothing provides glassfish-servlet-api >= 3.1.0 needed by eclipse-platform-1:4.19-5.fc35.x86_64
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.

P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors.

P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Mat Booth 2021-05-26 10:41:29 UTC
Works for me, installing from koji buildroot with "mock -r fedora-rawhide-x86_64 --enablerepo=local --install eclipse-pde"

Comment 2 Miro Hrončok 2021-05-26 11:04:22 UTC
Actually, `--enablerepo=local` only adds the Koji buildroot repo, while outdated rawhide repos are still available. Use `--disablerepo='*' --enablerepo=local` to replicate the Koji buildroot situation:

$ mock -r fedora-rawhide-x86_64 --disablerepo='*' --enablerepo=local --install eclipse-pde
Error: 
 Problem: conflicting requests
  - nothing provides osgi(org.objectweb.asm) needed by eclipse-pde-1:4.19-5.fc35.x86_64
  - nothing provides osgi(org.objectweb.asm.tree) needed by eclipse-pde-1:4.19-5.fc35.x86_64
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

Comment 3 Miro Hrončok 2021-05-26 11:06:37 UTC
$ mock -r fedora-rawhide-x86_64 --disablerepo='*' --enablerepo=local --install eclipse-jdt
...
Error: 
 Problem: conflicting requests
  - nothing provides osgi(org.hamcrest.core) needed by eclipse-jdt-1:4.19-5.fc35.noarch
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

Comment 4 Mat Booth 2021-05-26 13:00:35 UTC
(In reply to Miro Hrončok from comment #3)
> $ mock -r fedora-rawhide-x86_64 --disablerepo='*' --enablerepo=local
> --install eclipse-jdt
> ...
> Error: 
>  Problem: conflicting requests
>   - nothing provides osgi(org.hamcrest.core) needed by
> eclipse-jdt-1:4.19-5.fc35.noarch
> (try to add '--skip-broken' to skip uninstallable packages or '--nobest' to
> use not only best candidate packages)



I see, it would have been useful to include reproduction instructions in the bug you filed.

Comment 5 Miro Hrončok 2021-05-26 13:09:35 UTC
Yes indeed. I thought the same and adapting the bug template is on my TODO.

Comment 6 Miro Hrončok 2021-06-07 20:34:32 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 7 Miro Hrončok 2021-06-30 11:31:05 UTC
Hello,

This is the second reminder (step 4 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 8 Sergio Basto 2021-07-04 02:32:41 UTC
"osgi(org.hamcrest.core)" is hamcrest-core , this maybe happens because hamcrest2 was retired [1] and hamcrest [2] is now  hamcrest-2.2-4.fc35 


[1] 
https://src.fedoraproject.org/rpms/hamcrest2

[2]
https://src.fedoraproject.org/rpms/hamcrest

Comment 9 Mikolaj Izdebski 2021-07-04 11:02:43 UTC
It is likely that hamcrest upgrade to version 2 changed OSGi metadata or broke OSGi provides. 
If there are any hamcrest changes needed to fix eclipse, please open a bug against hamcrest package.

Comment 10 Sergio Basto 2021-07-09 21:52:11 UTC
Trying help here with some information , yes new hamcrest broke OSGi provides [1] 
but is just need in requires [2] enabling bootstrap and try to build the build stops on [3] https://kojipkgs.fedoraproject.org//work/tasks/9222/71609222/build.log
and I guess that fix OSGi provides of hamcrest will not fix the build isn't it ? 


[1] 
dnf repoquery --disablerepo='*' --enablerepo=rawhide -q hamcrest --provides
hamcrest = 2.2-4.fc35
hamcrest-core = 2.2-4.fc35
mvn(org.hamcrest:hamcrest) = 2.2
mvn(org.hamcrest:hamcrest-all) = 2.2
mvn(org.hamcrest:hamcrest-all:pom:) = 2.2
mvn(org.hamcrest:hamcrest-core) = 2.2
mvn(org.hamcrest:hamcrest-core:pom:) = 2.2
mvn(org.hamcrest:hamcrest-library) = 2.2
mvn(org.hamcrest:hamcrest-library:pom:) = 2.2
mvn(org.hamcrest:hamcrest:pom:) = 2.2

[2]
-Requires:       osgi(org.hamcrest.core)
+Requires:       mvn(org.hamcrest:hamcrest-core)

[3] 
[WARNING] Error initializing: org.eclipse.tycho.p2.resolver.P2DependencyResolver@7a358613
java.lang.RuntimeException: java.lang.IllegalStateException: Service is not registered class='interface org.eclipse.tycho.core.shared.ProxyServiceFacade' 

https://kojipkgs.fedoraproject.org//work/tasks/9222/71609222/build.log

Comment 11 Alexander Kurtakov 2021-07-12 07:29:16 UTC
(In reply to Sergio Basto from comment #10)
> Trying help here with some information , yes new hamcrest broke OSGi
> provides [1] 
> but is just need in requires [2] enabling bootstrap and try to build the
> build stops on [3]
> https://kojipkgs.fedoraproject.org//work/tasks/9222/71609222/build.log
> and I guess that fix OSGi provides of hamcrest will not fix the build isn't
> it ? 
> 
> 
> [2]
> -Requires:       osgi(org.hamcrest.core)
> +Requires:       mvn(org.hamcrest:hamcrest-core)
> 

Change like ^^ will ensure that jar is there but without OSGi metadata it's useless from Eclipse POV. My team no longer has the manpower to maintain Eclipse in Fedora so it's up to community to pick it up. Mat is the official maintainer but he is no longer in the team so I don't know about his plans.

Comment 12 Fedora Admin user for bugzilla script actions 2021-07-31 00:05:38 UTC
This package has changed maintainer in Fedora. Reassigning to the new maintainer of this component.

Comment 13 Miro Hrončok 2021-08-02 09:26:43 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 14 Didik Supriadi 2021-08-07 10:11:04 UTC
Hi,

I'm sorry if I'm wrong but isn't hamcrest version 2.* should be in "hamcrest2"?

"decathorpe" created it about a year ago, but orphaned it later due to lack of time.
Probably he's thinking that it's best to differentiate between the two?

Comment 15 Didik Supriadi 2021-08-07 10:12:50 UTC
link: https://src.fedoraproject.org/rpms/hamcrest2

Comment 16 Sergio Basto 2021-08-09 16:11:03 UTC
Some information from this thread [1]

According Mikolaj Izdebski 
- eclipse can easily remove dependency on jmc.
- Only jmc directly depends on HdrHistogram, nothing else.
- Only jmc directly depends on jmc-core
- Only jmc and jmc-core directly depend on owasp-java-encoder, nothing else.

[1] https://lists.fedoraproject.org/archives/list/java-devel@lists.fedoraproject.org/message/ZZNAIUM2EB6WK5J65TPD7DRHP2LH327C/

Comment 17 Miro Hrončok 2021-08-09 18:11:38 UTC
Sergio, are you working on this?

Comment 18 Ben Cotton 2021-08-10 13:04:01 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 35 development cycle.
Changing version to 35.

Comment 19 Sergio Basto 2021-08-10 14:19:29 UTC
(In reply to Miro Hrončok from comment #17)
> Sergio, are you working on this?

not really, I'm kjust trying understand the problem , now trying build eclipse on rawhide we got [1] even with bootstrap enabled 

jakarta.annotation-api on F35 stopped to provide osgi(jakarta.annotation-api) , without any great modification of the spec ... 

and eclipse-platform is part of eclipse.src.rpm so this is in loop .
eclipse-ecf-core requires eclipse-platform ( "osgi(org.eclipse.core.net)" )  

cbi-plugins requires tycho which requires eclipse-platform, any tip ? 

[1]
Error:
Problem 1: package tycho-2.2.0-4.fc34.noarch requires eclipse-platform >= 1:4.17, but none of the providers can be installed
- conflicting requests
- nothing provides osgi(jakarta.annotation-api) needed by eclipse-platform-1:4.19-5.fc35.x86_64
Problem 2: package eclipse-ecf-core-3.14.19-2.fc34.noarch requires osgi(org.eclipse.core.jobs), but none of the providers can be installed
- package eclipse-ecf-core-3.14.19-2.fc34.noarch requires osgi(org.eclipse.core.net), but none of the providers can be installed
- conflicting requests
- nothing provides osgi(jakarta.annotation-api) needed by eclipse-platform-1:4.19-5.fc35.x86_64
Problem 3: package cbi-plugins-1.1.7-10.fc35.noarch requires mvn(org.eclipse.tycho:tycho-core), but none of the providers can be installed
- package tycho-2.2.0-4.fc34.noarch requires eclipse-platform >= 1:4.17, but none of the providers can be installed
- conflicting requests
- nothing provides osgi(jakarta.annotation-api) needed by eclipse-platform-1:4.19-5.fc35.x86_64
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

Comment 20 Miro Hrončok 2021-08-10 23:27:06 UTC
If somebody plans to actually fix this until Fedora 35 beta freeze, please assign this buzgilla to you and set ti to ASSIGNED or higher before 2021-08-17, otherwise this package will be retired. Unretiring it once fixed is possible as well.

Comment 21 Sergio Basto 2021-08-10 23:56:23 UTC
I can't build tycho on F35/rawhide bug #1988028 , even if with local build of maven-install-plugin in buildroot, maven-install-plugin is retired and even if I enable bootstrap in tycho , also readd bnd-maven-plugin-5.2.0 in buildroot doesn't solve . 
error in tycho is similar when we try to eclipse [1] 

ah about the tip, seems we need build tycho with bootstrap , after eclipse with bootstrap, after tycho without bootstrap and finally eclipse without bootstrap.

But I don't see  way to solve this , I give up .


[1] 
[WARNING] Error initializing: org.eclipse.tycho.p2.resolver.P2DependencyResolver@443a06ad
java.lang.RuntimeException: java.lang.IllegalStateException: Service is not registered class='interface org.eclipse.tycho.core.shared.ProxyServiceFacade'

Comment 22 Miro Hrončok 2021-08-12 18:59:33 UTC
This package has been orphaned.

You can pick it up at https://src.fedoraproject.org/rpms/eclipse by clicking button "Take". If nobody picks it up, it will be retired and removed from a distribution.

Comment 23 Adam Williamson 2021-08-13 18:34:58 UTC
note, this breaks the Scientific_KDE spin, because it tries to pull in various of these eclipse subpackages which fail to install.

Comment 24 Miro Hrončok 2021-08-18 08:28:15 UTC
Automation has figured out the package is retired in Fedora 35.

If you like it to be unretired, please open a ticket at https://pagure.io/releng/new_issue?template=package_unretirement

Comment 25 Sergio Basto 2021-08-18 11:40:16 UTC
what are the packages that are F35FailsToInstall now with this retirement , isn't all java stack ?

Comment 26 Miro Hrončok 2021-08-18 11:45:49 UTC
Packages that needed eclipse to install already failed to install because eclipse did not install, so there should be no much changed. Anyway, after the package is blocked in koji, new bugzillas will be reported.

Comment 27 Mat Booth 2021-08-18 11:57:19 UTC
Sergio, I will still keep ecj and jgit alive because other non-eclipse packages use them, and they are quite small and easy to maintain.

Only packages named eclipse-* should be failing. No other packages should have eclipse as part of their build process.

Comment 28 Sergio Basto 2021-08-18 13:54:41 UTC
Created attachment 1815214 [details]
reults of retire of eclipse

eclips-swt is installed on my vm with F35 and the deps on mvn(org.eclipse.swt:swt) will remove java-1.8.0-openjdk which will remove maven ...

Comment 29 Mat Booth 2021-08-18 16:47:40 UTC
(In reply to Sergio Basto from comment #28)
> Created attachment 1815214 [details]
> reults of retire of eclipse
> 
> eclips-swt is installed on my vm with F35 and the deps on
> mvn(org.eclipse.swt:swt) will remove java-1.8.0-openjdk which will remove
> maven ...

Did you inspect the dep chain? It's probably only openjfx that needs fixing. File a bug against openjfx package to drop support for SWT.