Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1964646

Summary: F35FailsToInstall: perl-Crypt-PWSafe3
Product: [Fedora] Fedora Reporter: Miro Hrončok <mhroncok>
Component: perl-Crypt-PWSafe3Assignee: Charles R. Anderson <cra>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 35CC: axel.sommerfeldt, cra, mkreder, perl-devel, ppisar
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: perl-Crypt-PWSafe3-1.23~20220227git002b0f0-1.fc34 perl-Crypt-PWSafe3-1.23~20220227git002b0f0-1.fc35 perl-Crypt-PWSafe3-1.23~20220227git002b0f0-1.fc36 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2022-03-09 19:15:47 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 1939424    
Bug Blocks: 1927313, 1992487    

Description Miro Hrončok 2021-05-25 19:29:42 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok).

Your package (perl-Crypt-PWSafe3) Fails To Install in Fedora 35:

can't install perl-Crypt-PWSafe3:
  - nothing provides perl(:MODULE_COMPAT_5.32.1) needed by perl-Crypt-PWSafe3-1.22-17.fc34.noarch
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.

P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors.

P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Miro Hrončok 2021-06-07 20:34:51 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 2 Charles R. Anderson 2021-06-11 12:07:35 UTC
This package actually FTBFS due to the change in perl-Crypt-CBC from version 2.33 (fc33) to 3.01 (fc34) or 3.04 (fc35):

https://koji.fedoraproject.org/koji/buildinfo?buildID=1753588

+ make test
PERL_DL_NONLAZY=1 "/usr/bin/perl" "-MExtUtils::Command::MM" "-MTest::Harness" "-e" "undef *Test::Harness::Switches; test_harness(0, 'blib/lib', 'blib/arch')" t
/*.t
#   Failed test 'open a pwsafe3 database ('blocksize' is not a recognized argument at /usr/share/perl5/vendor_perl/Crypt/CBC.pm line 312.
#  at /builddir/build/BUILD/Crypt-PWSafe3-1.22/blib/lib/Crypt/PWSafe3.pm line 259.
# )'
#   at t/run.t line 71.
#   Failed test 'create a new pwsafe3 database ('blocksize' is not a recognized argument at /usr/share/perl5/vendor_perl/Crypt/CBC.pm line 312.
#  at /builddir/build/BUILD/Crypt-PWSafe3-1.22/blib/lib/Crypt/PWSafe3.pm line 197.
# )'
#   at t/run.t line 86.
#   Failed test 'read created new pwsafe3 database (PWSafe3 file /tmp/.myvault04yoeB_f does not exist or is not readable at t/run.t line 33.
# )'
#   at t/run.t line 95.
#   Failed test 'Write record to a new pwsafe3 database'
#   at t/run.t line 96.
#     Structures begin differing at:
#          $got->{passwd} = 'p3'
#     $expected->{passwd} = Does not exist
#   Failed test 'read a pwsafe3 database and change a record, traditional method ('blocksize' is not a recognized argument at /usr/share/perl5/vendor_perl/Cryp
t/CBC.pm line 312.
#  at /builddir/build/BUILD/Crypt-PWSafe3-1.22/blib/lib/Crypt/PWSafe3.pm line 259.
# )'
#   at t/run.t line 121.
#   Failed test 'Change a record an check if changes persist after saving, traditional method'
#   at t/run.t line 122.
#     Structures begin differing at:
#          $got->{passwd} = 'p3'
#     $expected->{passwd} = Does not exist
# 3 done
#   Failed test 'read a pwsafe3 database and change a record, new method ('blocksize' is not a recognized argument at /usr/share/perl5/vendor_perl/Crypt/CBC.pm
 line 312.
#  at /builddir/build/BUILD/Crypt-PWSafe3-1.22/blib/lib/Crypt/PWSafe3.pm line 259.
# )'
#   at t/run.t line 143.
Can't call method "notes" on an undefined value at t/run.t line 144.
# Looks like your test exited with 255 just after 9.
t/run.t .. 
Dubious, test returned 255 (wstat 65280, 0xff00)
Failed 11/13 subtests 
Test Summary Report
-------------------
t/run.t (Wstat: 65280 Tests: 9 Failed: 7)
  Failed tests:  3-9
  Non-zero exit status: 255
  Parse errors: Bad plan.  You planned 13 tests but ran 9.
Files=1, Tests=9,  1 wallclock secs ( 0.01 usr  0.00 sys +  0.12 cusr  0.01 csys =  0.14 CPU)
Result: FAIL
Failed 1/1 test programs. 7/9 subtests failed.
make: *** [Makefile:770: test_dynamic] Error 255

Comment 3 Ben Cotton 2021-08-10 13:04:06 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 35 development cycle.
Changing version to 35.

Comment 4 Charles R. Anderson 2021-11-04 15:39:43 UTC
*** Bug 2020246 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2022-03-02 04:33:04 UTC
FEDORA-2022-e541fc8d0d has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-e541fc8d0d

Comment 6 Fedora Update System 2022-03-02 04:33:56 UTC
FEDORA-2022-9af00d105b has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2022-9af00d105b

Comment 7 Fedora Update System 2022-03-02 04:34:43 UTC
FEDORA-2022-2fa03c4f5d has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2022-2fa03c4f5d

Comment 8 Fedora Update System 2022-03-02 15:56:36 UTC
FEDORA-2022-2fa03c4f5d has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-2fa03c4f5d`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-2fa03c4f5d

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 9 Fedora Update System 2022-03-02 16:15:52 UTC
FEDORA-2022-9af00d105b has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-9af00d105b`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-9af00d105b

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Fedora Update System 2022-03-02 19:43:19 UTC
FEDORA-2022-e541fc8d0d has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-e541fc8d0d`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-e541fc8d0d

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 11 Miro Hrončok 2022-03-02 22:17:45 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok).

All subpackages of a package against which this bug was filled are now installable or removed from Fedora 37.

Thanks for taking care of it!

Comment 12 Fedora Update System 2022-03-09 19:15:47 UTC
FEDORA-2022-2fa03c4f5d has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 13 Fedora Update System 2022-03-09 19:43:17 UTC
FEDORA-2022-9af00d105b has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 14 Fedora Update System 2022-03-26 15:06:36 UTC
FEDORA-2022-e541fc8d0d has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.