Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1964647

Summary: F35FailsToInstall: perl-Debug-Client
Product: [Fedora] Fedora Reporter: Miro Hrončok <mhroncok>
Component: perl-Debug-ClientAssignee: Orphan Owner <extras-orphan>
Status: CLOSED CANTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: jplesnik, mmaslano, perl-devel, ppisar
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: fedora-obsolete-packages-35-12 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-07-16 08:30:40 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1927313, 1964651    

Description Miro Hrončok 2021-05-25 19:29:44 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok).

Your package (perl-Debug-Client) Fails To Install in Fedora 35:

can't install perl-Debug-Client:
  - nothing provides perl(:MODULE_COMPAT_5.32.1) needed by perl-Debug-Client-0.31-13.fc34.noarch
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.

P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors.

P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Miro Hrončok 2021-06-07 20:34:54 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 2 Jitka Plesnikova 2021-06-08 14:15:49 UTC
I orphaned the package.

Comment 3 Miro Hrončok 2021-06-08 22:33:47 UTC
This package has been orphaned.

You can pick it up at https://src.fedoraproject.org/rpms/perl-Debug-Client by clicking button "Take". If nobody picks it up, it will be retired and removed from a distribution.

Comment 4 Fedora Admin user for bugzilla script actions 2021-06-09 00:10:37 UTC
This package has changed maintainer in Fedora. Reassigning to the new maintainer of this component.

Comment 5 Petr Pisar 2021-07-16 08:30:40 UTC
This bug is known to an upstream since 2020-09-26 without any response. We don't know how to fix it properly. This package is only used for perl-Padre which itself is upstream-dead for many years.

Removed from Fedora 35.