Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1967536

Summary: selinux denies "search" of "dma_heap"
Product: [Fedora] Fedora Reporter: Marius Vollmer <mvollmer>
Component: selinux-policyAssignee: Zdenek Pytela <zpytela>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: 33CC: dwalsh, grepl.miroslav, ifont, lvrabec, mmalik, mnk, omosnace, tino.wolf.1980, vkadlcik, vmojzis, zpytela
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: selinux-policy-3.14.6-39.fc33 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-07-18 01:03:21 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Marius Vollmer 2021-06-03 10:28:24 UTC
Description of problem:

A recent Fedora 33 image created with updates-testing has some new unexpected audit messages:

audit: type=1400 audit(1622712108.353:391): avc:  denied  { search } for  pid=1757 comm="systemd-udevd" name="dma_heap" dev="devtmpfs" ino=127 scontext=system_u:system_r:udev_t:s0-s0:c0.c1023 tcontext=system_u:object_r:dma_device_t:s0 tclass=dir permissive=0

Version-Release number of selected component (if applicable):
selinux-policy-3.14.6-38.fc33.noarch

Additional info:

This is the log of creating the image: https://logs-https-frontdoor.apps.ocp.ci.centos.org/logs/image-refresh-2075-20210603-083131/log

Here is a typical journal: https://logs.cockpit-project.org/logs/pull-2075-20210603-084927-61bae4f6-fedora-testing-cockpit-project-cockpit/TestNetworkingMAC-testBondMac-fedora-testing-127.0.0.2-2601-FAIL.log.gz

Comment 1 Zdenek Pytela 2021-06-03 12:52:49 UTC
Will be backported to F33 as soon as the rawhide PR is merged.
https://github.com/fedora-selinux/selinux-policy/pull/763

Comment 2 Ivan Font 2021-07-02 00:36:17 UTC
To work around:

$ sudo setenforce 0
$ sudo chcon system_u:object_r:device_t:s0 /dev/dma_heap/
$ sudo setenforce 1

Comment 3 Fedora Update System 2021-07-02 08:42:52 UTC
FEDORA-2021-3b341e9e71 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2021-3b341e9e71

Comment 4 Fedora Update System 2021-07-03 01:04:31 UTC
FEDORA-2021-3b341e9e71 has been pushed to the Fedora 33 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-3b341e9e71`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-3b341e9e71

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 5 Zdenek Pytela 2021-07-07 13:40:19 UTC
*** Bug 1976502 has been marked as a duplicate of this bug. ***

Comment 6 Mathias Nicolajsen Kjærgaard 2021-07-08 21:33:41 UTC
I can confirm that the update has fixed the issue on my system - after a reboot.

Comment 7 Zdenek Pytela 2021-07-09 07:20:42 UTC
Reboot or

restorecon -Rv /dev/dma_heap

is required in F33.

Comment 8 Fedora Update System 2021-07-18 01:03:21 UTC
FEDORA-2021-3b341e9e71 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.