Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 197501

Summary: wxGTK-devel should Require: libGLU-devel
Product: [Fedora] Fedora Reporter: Paul Howarth <paul>
Component: wxGTKAssignee: Matthew Miller <mattdm>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: medium    
Version: 5CC: alain.portal, extras-qa
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 2.6.3-2.6.3.2.2 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-07-03 15:58:08 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 193531    

Description Paul Howarth 2006-07-03 11:56:48 UTC
Line 25 of /usr/include/wx-2.6/wx/gtk/glcanvas.h in the wxGTK-devel package is:

#include <GL/glu.h>

This is pulling in a header file from libGLU-devel, hence it should be a
dependency of wxGTK-devel.

It also pulls in headers from libGL-devel, but since libGL-devel is itself a
dependency of libGLU-devel, libGL-devel will not be an issue if a libGLU-devel
dependency is added.

Comment 1 Matthew Miller 2006-07-03 13:04:34 UTC
Okay. Will add this next time I update.

Comment 2 Paul Howarth 2006-07-03 13:08:35 UTC
OK, but please bear in mind that packages using this are having to work around
the problem by buildrequiring libGLU-devel themselves at the moment (e.g. see
Bug #193531).

Comment 3 Matthew Miller 2006-07-03 13:09:42 UTC
*nod*

Comment 4 Matthew Miller 2006-07-03 15:58:08 UTC
Okay, since this was so trivial I just went ahead and did it. The update is
building now.