Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1977313

Summary: condor fails to build with Sphinx 4.0.2
Product: [Fedora] Fedora Reporter: Karolina Surma <ksurma>
Component: condorAssignee: Tim Theisen <tim>
Status: CLOSED NEXTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 35CC: bbockelm, bcotton, eerlands, matt, matyas, mhroncok, stclairt, steve.traylen, thrnciar, tim, trodgers, valtri
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: condor-8.8.15-1.fc35, condor-8.8.15-1.fc36 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-08-24 13:44:48 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1890881, 1927309, 1973718, 1992484, 1992487    

Description Karolina Surma 2021-06-29 12:56:45 UTC
condor fails to build with Sphinx 4.0.2 in Fedora 35 (currently Rawhide).

+ make -C docs man
make: Entering directory '/builddir/build/BUILD/htcondor-8_8_10/docs'
sphinx-build -b man -d _build/doctrees   . _build/man
Running Sphinx v4.0.2
WARNING: while setting up extension index: role 'index' is already registered, it will be overridden
making output directory... done
Exception occurred:
  File "/builddir/build/BUILD/htcondor-8_8_10/docs/conf.py", line 452, in setup
    app.add_stylesheet('css/htcondor-manual.css')
AttributeError: 'Sphinx' object has no attribute 'add_stylesheet'

For the logs from testing build attempts, see:
https://copr.fedorainfracloud.org/coprs/ksurma/pygments-2.9.0/package/condor/

Possible solution for this issue:
In some cases it may be enough to replace the call to 'add_stylesheet' with 'add_css_file' instead.


You can test you package using Koji scratch build
koji build --scratch <srpm>


For details regarding the Sphinx change, see https://fedoraproject.org/wiki/Changes/Sphinx4
Let us know here if you have any questions. Thank you!

Comment 1 Tim Theisen 2021-06-29 15:48:05 UTC
This is a problem with the included documentation for the Jupyter notebooks. The solution is to patch the documentation to point directly to the tutorials. Unfortunately, then this section of the manual is no longer available off-line. After patching this today, we will work on getting the python notebook documentation back into the manual.

Comment 2 Miro Hrončok 2021-07-26 09:04:41 UTC
*** Bug 1967078 has been marked as a duplicate of this bug. ***

Comment 3 Ben Cotton 2021-08-10 13:09:41 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 35 development cycle.
Changing version to 35.

Comment 4 Miro Hrončok 2021-08-23 11:13:27 UTC
(In reply to Tim Theisen from comment #1)
> This is a problem with the included documentation for the Jupyter notebooks.
> The solution is to patch the documentation to point directly to the
> tutorials. Unfortunately, then this section of the manual is no longer
> available off-line. After patching this today, we will work on getting the
> python notebook documentation back into the manual.

Hey Tim. Any update on this? Can we at least temporarily disable the documentation build to make python3-condor installable again?

Comment 5 Tim Theisen 2021-08-23 15:44:21 UTC
Hello Miro,

I push an update today.

Thank you for your patience.

...Tim

Comment 6 Tim Theisen 2021-08-24 04:41:46 UTC
*** Bug 1992884 has been marked as a duplicate of this bug. ***

Comment 7 Miro Hrončok 2021-08-24 10:27:23 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok).

All subpackages of a package against which this bug was filled are now installable or removed from Fedora 35.

Thanks for taking care of it!

Comment 8 Miro Hrončok 2021-08-24 12:02:32 UTC
This was only built on F35, could you also build in Rawhide?

Comment 9 Tim Theisen 2021-08-24 13:28:24 UTC
I have built for rawhide as well. Can this be closed now?

Comment 10 Miro Hrončok 2021-08-24 13:44:48 UTC
Yes, thank you!