Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1977513

Summary: F35FailsToInstall: python3-typer
Product: [Fedora] Fedora Reporter: Miro Hrončok <mhroncok>
Component: python-typerAssignee: Ben Beasley <code>
Status: CLOSED ERRATA QA Contact:
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 35CC: code, thrnciar
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: python-typer-0.4.0-1.fc35 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-08-30 17:39:33 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1890881, 1927313, 1974118, 1987894    

Description Miro Hrončok 2021-06-29 23:45:19 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok).

Your package (python-typer) Fails To Install in Fedora 35:

can't install python3-typer:
  - nothing provides (python3.10dist(click) < 7.2 with python3.10dist(click) >= 7.1.1) needed by python3-typer-0.3.2-3.fc35.noarch
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.

P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors.

P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Ben Beasley 2021-06-30 01:30:09 UTC
This is caused by the recent update to python-click 8.x in Rawhide, with which typer is not yet compatible (https://github.com/tiangolo/typer/issues/280). Unfortunately, a nontrivial patch will be required, and so far none exists. It’s unlikely I will have enough time to dig deeply into both projects and develop the necessary patch myself.

I’ll keep an eye on the situation upstream. Hopefully a patch, viable PR, or new release will surface in the next few weeks; we’re not the only ones asking for one.

Comment 2 Miro Hrončok 2021-06-30 09:02:56 UTC
Ben, we've tried to careful with this update, but apperently we were not careful enough, see https://src.fedoraproject.org/rpms/python-click/pull-request/10#comment-79724

I can untag the update for now (until it reaches rawhide compose, which it still didn't) or I can package python-click7 as a temporary compact package. Let me know if you need one of those things.

Comment 3 Ben Beasley 2021-06-30 12:57:44 UTC
What do you think is best?

I just introduced python-typer less than two weeks ago, so at the moment it’s still a leaf package. It can be FTI temporarily as long as it gets fixed.

I can’t tell if upstream is going to come through with support in time for Fedora 35 or not; and if they don’t, I can’t tell if it’s something I could fix myself in a couple of hours or not.

Comment 4 Miro Hrončok 2021-06-30 13:08:44 UTC
> It can be FTI temporarily as long as it gets fixed.

Sure. Let's wait for upstream fix and don't hesitate to ping me near the the beta freeze if this needs a workaround.

Comment 6 Miro Hrončok 2021-08-02 10:08:56 UTC
*** Bug 1989027 has been marked as a duplicate of this bug. ***

Comment 7 Ben Cotton 2021-08-10 13:10:03 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 35 development cycle.
Changing version to 35.

Comment 8 Ben Beasley 2021-08-20 19:03:41 UTC
I’ve announced my intent to retire this and python-typer-cli since upstream has not even showed signs of working on this.

https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/33BAFLW7URTBY56NFVRGW6VDIKQUAT6I/

Comment 9 Ben Beasley 2021-08-27 13:34:10 UTC
The package is retired in F35 and Rawhide.

Comment 10 Ben Beasley 2021-08-30 11:46:38 UTC
Upstream suddenly reappeared and fixed the critical click incompatibility just a few days after I retired the package. I have requested unretirement in Rawhide and F35 (https://pagure.io/releng/issue/10288) and will provide an update to fix this issue.

Comment 11 Miro Hrončok 2021-08-30 17:26:41 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok).

All subpackages of a package against which this bug was filled are now installable or removed from Fedora 36.

Thanks for taking care of it!

Comment 12 Miro Hrončok 2021-08-30 17:39:33 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok).

All subpackages of a package against which this bug was filled are now installable or removed from Fedora 35.

Thanks for taking care of it!

Comment 13 Fedora Update System 2021-08-31 17:57:36 UTC
FEDORA-2021-921e7445a7 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-921e7445a7`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-921e7445a7

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 14 Fedora Update System 2021-09-24 20:12:18 UTC
FEDORA-2021-921e7445a7 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.