Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1982396

Summary: Golang 1.17
Product: [Fedora] Fedora Reporter: Ben Cotton <bcotton>
Component: Changes TrackingAssignee: Alejandro Sáez Morollón <asm>
Status: CLOSED DEFERRED QA Contact:
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: asm, bcotton, jcajka
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2022-01-06 17:32:50 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Ben Cotton 2021-07-14 18:50:21 UTC
This is a tracking bug for Change: Golang 1.17
For more details, see: https://fedoraproject.org/wiki/Changes/golang1.17

Rebase of Golang package to upcoming version 1.17 in Fedora 35, including the rebuild of all dependent packages(the pre-release version of Go will be used for the rebuild if released version will not be available at the time of the mass rebuild).

If you encounter a bug related to this Change, please do not comment here. Instead create a new bug and set it to block this bug.

Comment 1 Ben Cotton 2021-08-10 12:32:56 UTC
Today is the "Code complete (testable)" deadline in the Fedora Linux 35 release schedule:
https://fedorapeople.org/groups/schedule/f-35/f-35-key-tasks.html

If this Change is complete enough to be tested, please indicate this by setting this bug to the MODIFIED status. (If it is 100% complete, you can set it to ON_QA).

If you wish to defer this Change to Fedora Linux 36, please needinfo bcotton.

Comment 2 Alejandro Sáez Morollón 2021-08-10 12:57:35 UTC
@bcotton 

I was planning on doing a build on rawhide and then try it on f35 before the freeze. Does it sound ok? Is there any other alternative?

Comment 3 Ben Cotton 2021-08-10 17:08:19 UTC
That works for me unless FESCo objects. I'll include that note in the list I give them tomorrow.

Comment 4 Alejandro Sáez Morollón 2021-08-19 13:19:25 UTC
As I commented in the FESCo issue #2660 [0], 225 packages of ~1800 failed to build with Go 1.17.0 on rawhide. Not sure about the next steps. any tips? @bencotton

[0] https://pagure.io/fesco/issue/2660#comment-748390

Comment 5 Ben Cotton 2021-08-20 17:20:56 UTC
You already asked FESCo, so I'll defer to their guidance. In general, I would say that so long as none of the FTBFS packages are in the critical path, it's fine to move forward with that level of failures and work with package owners to fix them. But since we're days away from Beta freeze, it might be better to defer this.

Comment 6 Ben Cotton 2021-08-24 13:17:47 UTC
Deferred to F36 by FESCo.

Comment 7 Alejandro Sáez Morollón 2021-12-16 18:18:57 UTC
I submitted a new proposal because we are planning on having Go 1.18 instead of the original proposal with 1.17

https://fedoraproject.org/wiki/Changes/golang1.18

Comment 8 Ben Cotton 2022-01-06 17:32:50 UTC
This change is replaced by #2037868.