Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1983917

Summary: F35FailsToInstall: Multiple packages built from rust-crosstermion
Product: [Fedora] Fedora Reporter: Miro Hrončok <mhroncok>
Component: rust-crosstermionAssignee: Rust SIG <rust-sig>
Status: CLOSED WORKSFORME QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: igor.raits, rust-sig
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-07-22 09:40:37 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1927313    

Description Miro Hrončok 2021-07-20 07:39:22 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok).

Your package (rust-crosstermion) Fails To Install in Fedora 35:

can't install rust-crosstermion+tui-crossterm-backend-devel:
  - nothing provides (crate(tui/crossterm) >= 0.14.0 with crate(tui/crossterm) < 0.15.0~) needed by rust-crosstermion+tui-crossterm-backend-devel-0.6.0-2.fc34.noarch
  
can't install rust-crosstermion+tui-crossterm-devel:
  - nothing provides (crate(tui) >= 0.14.0 with crate(tui) < 0.15.0~) needed by rust-crosstermion+tui-crossterm-devel-0.6.0-2.fc34.noarch
  
can't install rust-crosstermion+tui-devel:
  - nothing provides (crate(tui) >= 0.14.0 with crate(tui) < 0.15.0~) needed by rust-crosstermion+tui-devel-0.6.0-2.fc34.noarch
  
can't install rust-crosstermion+tui-react-crossterm-devel:
  - nothing provides (crate(tui) >= 0.14.0 with crate(tui) < 0.15.0~) needed by rust-crosstermion+tui-react-crossterm-devel-0.6.0-2.fc34.noarch
  
can't install rust-crosstermion+tui-react-termion-devel:
  - nothing provides (crate(tui) >= 0.14.0 with crate(tui) < 0.15.0~) needed by rust-crosstermion+tui-react-termion-devel-0.6.0-2.fc34.noarch
  
can't install rust-crosstermion+tui-termion-devel:
  - nothing provides (crate(tui) >= 0.14.0 with crate(tui) < 0.15.0~) needed by rust-crosstermion+tui-termion-devel-0.6.0-2.fc34.noarch
  
can't install rust-crosstermion+tui-termion-backend-devel:
  - nothing provides (crate(tui/termion) >= 0.14.0 with crate(tui/termion) < 0.15.0~) needed by rust-crosstermion+tui-termion-backend-devel-0.6.0-2.fc34.noarch
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.

P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors.

P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Miro Hrončok 2021-07-22 09:40:37 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok).

All subpackages of a package against which this bug was filled are now installable or removed from Fedora 35.

Thanks for taking care of it!