Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1999445

Summary: [F36FTBFS]: dee fails to build from source in Fedora Rawhide
Product: [Fedora] Fedora Reporter: Ondrej Dubaj <odubaj>
Component: valaAssignee: Felipe Borges <feborges>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: awilliam, fabian.deutsch, feborges, jspaleta, michel, spotrh, thrnciar, zeenix
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2022-01-10 19:25:56 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1936597, 1992484, 2016048    

Description Ondrej Dubaj 2021-08-31 08:04:39 UTC
Your package fails to build with the newest autoconf-2.71, which was part of a recent wide Fedora change. More information about Fedora autoconf Change available here: https://fedoraproject.org/wiki/Changes/Autoconf_271#How_To_Test. The easiest way to reproduce the problem is to execute a fedora scratch-build on your package. Thank you for cooperation!

Comment 1 Tom "spot" Callaway 2021-08-31 15:24:55 UTC
This is not an autoconf issue, this is because of vala 0.53, and just like last time vala updated and broke dee, I have no clue what to adjust to fix it. :/

Comment 2 Felipe Borges 2021-09-01 08:02:39 UTC
Seems like the same as https://bugzilla.redhat.com/show_bug.cgi?id=1999471

Comment 3 Tom "spot" Callaway 2021-09-16 16:43:55 UTC
Still broken with vala-0.53.2-1.fc36:

/usr/bin/vapigen --pkg gio-2.0 --library dee-1.0 --metadatadir=. ../src/Dee-1.0.gir Dee-1.0-custom.vala
Dee-1.0.gir:1180.7-1180.58: warning: Field `Dee.Filter.destroy' conflicts with method of the same name
      <method name="destroy" c:identifier="dee_filter_destroy">
      ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
Dee-1.0.gir:1274.7-1274.42: error: `Dee.Filter' already contains a definition for `new'
      <function name="new" c:identifier="dee_filter_new">
      ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
Dee-1.0-custom.vala:19.3-19.27: note: previous definition of `new' was here
		public static Filter @new (Dee.StaticFilterMapFunc map_func, owned Dee.FilterMapNotify map_notify);
		^^^^^^^^^^^^^^^^^^^^^^^^^
Dee-1.0.gir:8618.7-8618.70: warning: Field `Dee.ModelReader.destroy' conflicts with method of the same name
      <method name="destroy" c:identifier="dee_model_reader_destroy">
      ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
Generation failed: 1 error(s), 2 warning(s)
make[2]: *** [Makefile:569: dee-1.0.vapi] Error 1
make[2]: Leaving directory '/builddir/build/BUILD/dee-1.2.7/vapi'
make[1]: *** [Makefile:527: all-recursive] Error 1
make[1]: Leaving directory '/builddir/build/BUILD/dee-1.2.7'
make: *** [Makefile:433: all] Error 2

Comment 4 Miro HronĨok 2021-11-01 09:33:58 UTC
The following builds were made after this report was opened: vala-0.53.1-2.fc36 vala-0.53.2-1.fc36 vala-0.54.0-1.fc36 vala-0.54.1-1.fc36 vala-0.54.2-1.fc36 vala-0.54.3-1.fc36

Comment 5 Tom "spot" Callaway 2022-01-10 17:54:25 UTC
Still broken, same bug.

Comment 6 Tom "spot" Callaway 2022-01-10 18:03:36 UTC
*** Bug 2038928 has been marked as a duplicate of this bug. ***

Comment 7 Tom "spot" Callaway 2022-01-10 19:25:15 UTC
Patched around this in dee. Not sure if my approach is correct or not, but it builds, and all the dependencies (libunity, zeitgeist) build against it, so it can't be too wrong (hopefully).