Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1999460

Summary: [F36FTBFS]: libcircle fails to build from source in Fedora Rawhide
Product: [Fedora] Fedora Reporter: Ondrej Dubaj <odubaj>
Component: libcircleAssignee: Christoph Junghans <junghans>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: junghans
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-08-31 20:01:38 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1936597, 1992484    

Description Ondrej Dubaj 2021-08-31 08:05:46 UTC
Your package fails to build with the newest autoconf-2.71, which was part of a recent wide Fedora change. More information about Fedora autoconf Change available here: https://fedoraproject.org/wiki/Changes/Autoconf_271#How_To_Test. The easiest way to reproduce the problem is to execute a fedora scratch-build on your package. Thank you for cooperation!

Comment 1 Christoph Junghans 2021-08-31 16:06:36 UTC
I build it locally, no problems:

+ exit 0
Finish: rpmbuild libcircle-0.3-8.fc36.src.rpm
Finish: build phase for libcircle-0.3-8.fc36.src.rpm
INFO: Done(libcircle-0.3-8.fc36.src.rpm) Config(odubaj-autoconf-2.70_fedora-rawhide-x86_64) 4 minutes 31 seconds
INFO: Results and/or logs in: /var/lib/mock/odubaj-autoconf-2.70_fedora-rawhide-x86_64/result
Finish: run

Comment 2 Christoph Junghans 2021-08-31 20:01:38 UTC
Failure unrelated to autoconf, but fixed now.