Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1999515

Summary: [F36FTBFS]: proxysql fails to build from source in Fedora Rawhide
Product: [Fedora] Fedora Reporter: Ondrej Dubaj <odubaj>
Component: proxysqlAssignee: mkulik
Status: CLOSED WORKSFORME QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: acaringi, fjanus, hhorak, igor.raits, ljavorsk, mschorm
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-09-01 09:39:02 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1936597, 1992484    

Description Ondrej Dubaj 2021-08-31 08:10:05 UTC
Your package fails to build with the newest autoconf-2.71, which was part of a recent wide Fedora change. More information about Fedora autoconf Change available here: https://fedoraproject.org/wiki/Changes/Autoconf_271#How_To_Test. The easiest way to reproduce the problem is to execute a fedora scratch-build on your package. Thank you for cooperation!

Comment 1 mkulik 2021-09-01 09:25:00 UTC
No errors building on fedora:RH with autoconf-2.71-1.

This might be false positive error.

Comment 2 Michal Schorm 2021-09-01 09:39:02 UTC
The only issue I found by examining odubaj's KOJI build history is this error on Armv7hl builder:
  https://koji.fedoraproject.org/koji/taskinfo?taskID=74802925

I can see those later builds - also issued by odubaj - passing:
  https://koji.fedoraproject.org/koji/taskinfo?taskID=74842310
  https://koji.fedoraproject.org/koji/taskinfo?taskID=74910039

Since the issue seems not reproducible, I'm closing this ticket.