Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 2007965

Summary: Review Request: wget2 - An advanced file and recursive website downloader
Product: [Fedora] Fedora Reporter: Neal Gompa <ngompa13>
Component: Package ReviewAssignee: Petr Menšík <pemensik>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: akhaitov, package-review, pemensik
Target Milestone: ---Flags: pemensik: fedora-review+
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-10-11 21:33:13 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Neal Gompa 2021-09-26 15:00:01 UTC
Spec URL: https://ngompa.fedorapeople.org/for-review/wget2.spec
SRPM URL: https://ngompa.fedorapeople.org/for-review/wget2-2.0.0-1.fc35.src.rpm

Description:
GNU Wget2 is the successor of GNU Wget, a file and recursive website
downloader.

Designed and written from scratch it wraps around libwget, that provides the
basic functions needed by a web client.

Wget2 works multi-threaded and uses many features to allow fast operation.
In many cases Wget2 downloads much faster than Wget1.x due to HTTP2, HTTP
compression, parallel connections and use of If-Modified-Since HTTP header.


Fedora Account System Username: ngompa

Comment 1 Neal Gompa 2021-09-26 15:00:53 UTC
*** Bug 1822561 has been marked as a duplicate of this bug. ***

Comment 2 Petr Menšík 2021-10-10 18:05:05 UTC
Package Review
==============

Legend:
[x] = Pass, [!] = Fail, [-] = Not applicable, [?] = Not evaluated
[ ] = Manual review needed


Issues:
=======
- Provides: bundled(gnulib) in place as required.
  Note: Bundled gnulib but no Provides: bundled(gnulib)
  See:
  https://fedoraproject.org/wiki/Bundled_Libraries#Requirement_if_you_bundle
- If your application is a C or C++ application you must list a
  BuildRequires against gcc, gcc-c++ or clang.
  Note: No gcc, gcc-c++ or clang found in BuildRequires
  See: https://docs.fedoraproject.org/en-US/packaging-guidelines/C_and_C++/


===== MUST items =====

C/C++:
[x]: Package does not contain kernel modules.
[x]: Package contains no static executables.
[x]: Header files in -devel subpackage, if present.
[x]: ldconfig not called in %post and %postun for Fedora 28 and later.
[x]: Package does not contain any libtool archives (.la)
[x]: Rpath absent or only used for internal libs.
[x]: Development (unversioned) .so files in -devel subpackage, if present.

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. Licenses
     found: "Unknown or generated", "GNU Lesser General Public License,
     Version 3", "GNU General Public License v3.0 or later", "FSF All
     Permissive License", "GNU General Public License v3.0 or later
     [generated file]", "FSF Unlimited License (with Retention) [generated
     file]", "GNU Lesser General Public License GNU General Public License
     v3.0 or later", "GNU General Public License v2.0 or later [generated
     file]", "FSF Unlimited License (with Retention)", "FSF Unlimited
     License [generated file]", "MIT License [generated file]", "GNU
     General Public License v2.0 or later", "[generated file]", "GNU Free
     Documentation License v1.3 or later", "GNU Lesser General Public
     License v3.0 or later", "ISC License GNU General Public License v3.0
     or later", "BSD (3 clause) GNU General Public License v3.0 or later",
     "*No copyright* GNU Lesser General Public License v3.0 or later", "GNU
     Lesser General Public License", "FSF Unlimited License (with
     Retention) GNU Lesser General Public License GNU General Public
     License", "FSF Unlimited License (with Retention) GNU General Public
     License, Version 2", "GNU General Public License", "*No copyright*
     Mozilla Public License 2.0". 233 files have unknown license. Detailed
     output of licensecheck in
     /home/pihhan/fedora/review/2007965-wget2/licensecheck.txt
[x]: License file installed when any subpackage combination is installed.
[x]: %build honors applicable compiler flags or justifies otherwise.
[!]: Package contains no bundled libraries without FPC exception.
[x]: Changelog in prescribed format.
[x]: Sources contain only permissible code or content.
[-]: Package contains desktop file if it is a GUI application.
[x]: Development files must be in a -devel package
[x]: Package uses nothing in %doc for runtime.
[x]: The spec file handles locales properly.
[x]: Package consistently uses macros (instead of hard-coded directory
     names).
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
[x]: Package obeys FHS, except libexecdir and /usr/target.
[x]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Requires correct, justified where necessary.
[x]: Spec file is legible and written in American English.
[-]: Package contains systemd file(s) if in need.
[x]: Useful -debuginfo package or justification otherwise.
[x]: Package is not known to require an ExcludeArch tag.
[-]: Large documentation must go in a -doc subpackage. Large could be size
     (~1MB) or number of files.
     Note: Documentation size is 20480 bytes in 1 files.
[x]: Package complies to the Packaging Guidelines
[x]: Package successfully compiles and builds into binary rpms on at least
     one supported primary architecture.
[x]: Package installs properly.
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).
[x]: If (and only if) the source package includes the text of the
     license(s) in its own file, then that file, containing the text of the
     license(s) for the package is included in %license.
[x]: Package requires other packages for directories it uses.
[x]: Package must own all directories that it creates.
[x]: Package does not own files or directories owned by other packages.
[x]: Package uses either %{buildroot} or $RPM_BUILD_ROOT
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Dist tag is present.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Package must not depend on deprecated() packages.
[x]: Package use %makeinstall only when make install DESTDIR=... doesn't
     work.
[x]: Package is named using only allowed ASCII characters.
[x]: Package does not use a name that already exists.
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as
     provided in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: File names are valid UTF-8.
[x]: Packages must not store files under /srv, /opt or /usr/local

===== SHOULD items =====

Generic:
[x]: If the source package does not include license text(s) as a separate
     file from upstream, the packager SHOULD query upstream to include it.
[x]: Final provides and requires are sane (see attachments).
[x]: Fully versioned dependency in subpackages if applicable.
     Note: No Requires: %{name}%{?_isa} = %{version}-%{release} in
     wget2-libs , wget2-devel
[?]: Package functions as described.
[x]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[-]: Sources are verified with gpgverify first in %prep if upstream
     publishes signatures.
     Note: gpgverify is not used.
[-]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: Package should compile and build into binary rpms on all supported
     architectures.
[x]: %check is present and all tests pass.
[x]: Packages should try to preserve timestamps of original installed
     files.
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: Packager, Vendor, PreReq, Copyright tags should not be in spec file
[x]: The placement of pkgconfig(.pc) files are correct.
[x]: Sources can be downloaded from URI in Source: tag
[x]: SourceX is a working URL.
[x]: Spec use %global instead of %define unless justified.

===== EXTRA items =====

Generic:
[x]: Rpmlint is run on debuginfo package(s).
     Note: No rpmlint messages.
[x]: Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).
[x]: Large data in /usr/share should live in a noarch subpackage if package
     is arched.
[x]: Package should not use obsolete m4 macros
[x]: Spec file according to URL is the same as in SRPM.


Rpmlint
-------
Checking: wget2-2.0.0-1.fc36.x86_64.rpm
          wget2-libs-2.0.0-1.fc36.x86_64.rpm
          wget2-devel-2.0.0-1.fc36.x86_64.rpm
          wget2-debuginfo-2.0.0-1.fc36.x86_64.rpm
          wget2-debugsource-2.0.0-1.fc36.x86_64.rpm
          wget2-2.0.0-1.fc36.src.rpm
wget2.x86_64: W: spelling-error Summary(en_US) downloader -> downloaded, down loader, down-loader
wget2.x86_64: W: spelling-error %description -l en_US downloader -> downloaded, down loader, down-loader
wget2.x86_64: W: spelling-error %description -l en_US libwget -> libretto
wget2.x86_64: W: no-manual-page-for-binary wget2_noinstall
wget2-libs.x86_64: W: crypto-policy-non-compliance-gnutls-2 /usr/lib64/libwget.so.1.0.0 gnutls_priority_init
wget2-libs.x86_64: W: shared-lib-calls-exit /usr/lib64/libwget_common.so.1.0.0 exit.5
wget2-libs.x86_64: W: no-documentation
wget2.src: W: spelling-error Summary(en_US) downloader -> downloaded, down loader, down-loader
wget2.src: W: spelling-error %description -l en_US downloader -> downloaded, down loader, down-loader
wget2.src: W: spelling-error %description -l en_US libwget -> libretto
6 packages and 0 specfiles checked; 0 errors, 10 warnings.




Rpmlint (debuginfo)
-------------------
Checking: wget2-debuginfo-2.0.0-1.fc36.x86_64.rpm
          wget2-libs-debuginfo-2.0.0-1.fc36.x86_64.rpm
2 packages and 0 specfiles checked; 0 errors, 0 warnings.





Rpmlint (installed packages)
----------------------------
Cannot parse rpmlint output:


Source checksums
----------------
https://ftp.gnu.org/gnu/wget/wget2-2.0.0.tar.gz :
  CHECKSUM(SHA256) this package     : 4fe2fba0abb653ecc1cc180bea7f04212c17e8fe05c85aaac8baeac4cd241544
  CHECKSUM(SHA256) upstream package : 4fe2fba0abb653ecc1cc180bea7f04212c17e8fe05c85aaac8baeac4cd241544


Requires
--------
wget2 (rpmlib, GLIBC filtered):
    libc.so.6()(64bit)
    libgpgme.so.11()(64bit)
    libgpgme.so.11(GPGME_1.0)(64bit)
    libgpgme.so.11(GPGME_1.1)(64bit)
    libpcre2-8.so.0()(64bit)
    libwget.so.1()(64bit)
    rtld(GNU_HASH)
    wget2-libs(x86-64)

wget2-libs (rpmlib, GLIBC filtered):
    libassuan.so.0()(64bit)
    libbrotlidec.so.1()(64bit)
    libbz2.so.1()(64bit)
    libc.so.6()(64bit)
    libgnutls.so.30()(64bit)
    libgnutls.so.30(GNUTLS_3_4)(64bit)
    libgpg-error.so.0()(64bit)
    libgpgme.so.11()(64bit)
    libidn2.so.0()(64bit)
    libidn2.so.0(IDN2_0.0.0)(64bit)
    liblzma.so.5()(64bit)
    liblzma.so.5(XZ_5.0)(64bit)
    libnghttp2.so.14()(64bit)
    libpcre2-8.so.0()(64bit)
    libpsl.so.5()(64bit)
    libwget_alloc.so.1()(64bit)
    libwget_common.so.1()(64bit)
    libwget_dnscache.so.1()(64bit)
    libwget_encoding.so.1()(64bit)
    libwget_hashfile.so.1()(64bit)
    libwget_io.so.1()(64bit)
    libwget_ip.so.1()(64bit)
    libwget_iri.so.1()(64bit)
    libwget_logger.so.1()(64bit)
    libwget_thread.so.1()(64bit)
    libwget_xml.so.1()(64bit)
    libz.so.1()(64bit)
    libzstd.so.1()(64bit)
    rtld(GNU_HASH)

wget2-devel (rpmlib, GLIBC filtered):
    /usr/bin/pkg-config
    libwget.so.1()(64bit)
    libwget_alloc.so.1()(64bit)
    libwget_common.so.1()(64bit)
    libwget_css.so.1()(64bit)
    libwget_decompress.so.1()(64bit)
    libwget_dns.so.1()(64bit)
    libwget_dnscache.so.1()(64bit)
    libwget_encoding.so.1()(64bit)
    libwget_hashfile.so.1()(64bit)
    libwget_hpkp_db.so.1()(64bit)
    libwget_hsts.so.1()(64bit)
    libwget_http_parse.so.1()(64bit)
    libwget_io.so.1()(64bit)
    libwget_ip.so.1()(64bit)
    libwget_iri.so.1()(64bit)
    libwget_logger.so.1()(64bit)
    libwget_metalink.so.1()(64bit)
    libwget_netrc.so.1()(64bit)
    libwget_ocsp.so.1()(64bit)
    libwget_progress.so.1()(64bit)
    libwget_robots.so.1()(64bit)
    libwget_thread.so.1()(64bit)
    libwget_tls_session.so.1()(64bit)
    libwget_xml.so.1()(64bit)
    wget2-libs(x86-64)

wget2-debuginfo (rpmlib, GLIBC filtered):

wget2-debugsource (rpmlib, GLIBC filtered):



Provides
--------
wget2:
    wget2
    wget2(x86-64)

wget2-libs:
    libwget.so.1()(64bit)
    libwget_alloc.so.1()(64bit)
    libwget_common.so.1()(64bit)
    libwget_css.so.1()(64bit)
    libwget_decompress.so.1()(64bit)
    libwget_dns.so.1()(64bit)
    libwget_dnscache.so.1()(64bit)
    libwget_encoding.so.1()(64bit)
    libwget_hashfile.so.1()(64bit)
    libwget_hpkp_db.so.1()(64bit)
    libwget_hsts.so.1()(64bit)
    libwget_http_parse.so.1()(64bit)
    libwget_io.so.1()(64bit)
    libwget_ip.so.1()(64bit)
    libwget_iri.so.1()(64bit)
    libwget_logger.so.1()(64bit)
    libwget_metalink.so.1()(64bit)
    libwget_netrc.so.1()(64bit)
    libwget_ocsp.so.1()(64bit)
    libwget_progress.so.1()(64bit)
    libwget_robots.so.1()(64bit)
    libwget_thread.so.1()(64bit)
    libwget_tls_session.so.1()(64bit)
    libwget_xml.so.1()(64bit)
    wget2-libs
    wget2-libs(x86-64)

wget2-devel:
    pkgconfig(libwget)
    wget2-devel
    wget2-devel(x86-64)

wget2-debuginfo:
    debuginfo(build-id)
    wget2-debuginfo
    wget2-debuginfo(x86-64)

wget2-debugsource:
    wget2-debugsource
    wget2-debugsource(x86-64)



Generated by fedora-review 0.7.6 (b083f91) last change: 2020-11-10
Command line :/usr/bin/fedora-review -b 2007965
Buildroot used: fedora-rawhide-x86_64
Active plugins: C/C++, Generic, Shell-api
Disabled plugins: R, Perl, fonts, Ocaml, PHP, SugarActivity, Java, Haskell, Python
Disabled flags: EPEL6, EPEL7, DISTTAG, BATCH, EXARCH

Comment 3 Neal Gompa 2021-10-10 18:19:41 UTC
(In reply to Petr Menšík from comment #2)
> Package Review
> ==============
> 
> Legend:
> [x] = Pass, [!] = Fail, [-] = Not applicable, [?] = Not evaluated
> [ ] = Manual review needed
> 
> 
> Issues:
> =======
> - Provides: bundled(gnulib) in place as required.
>   Note: Bundled gnulib but no Provides: bundled(gnulib)
>   See:
>   https://fedoraproject.org/wiki/Bundled_Libraries#Requirement_if_you_bundle
> - If your application is a C or C++ application you must list a
>   BuildRequires against gcc, gcc-c++ or clang.
>   Note: No gcc, gcc-c++ or clang found in BuildRequires
>   See: https://docs.fedoraproject.org/en-US/packaging-guidelines/C_and_C++/

I've made the necessary fixes and updated the Spec and SRPM linked in the initial comment.

Comment 4 Petr Menšík 2021-10-10 18:20:50 UTC
It seems to me GFDL should be also in License tag:. Only docs/wget2.md is licensed under it, but I think it should be included also.

Comment 5 Neal Gompa 2021-10-10 18:23:18 UTC
(In reply to Petr Menšík from comment #4)
> It seems to me GFDL should be also in License tag:. Only docs/wget2.md is
> licensed under it, but I think it should be included also.

Done and refreshed spec + srpm.

Comment 6 Petr Menšík 2021-10-10 18:27:12 UTC
(In reply to Neal Gompa from comment #5)
> 
> Done and refreshed spec + srpm.

I am missing %doc docs/wget2.md. It is not yet installed.

Comment 7 Neal Gompa 2021-10-10 18:30:16 UTC
(In reply to Petr Menšík from comment #6)
> (In reply to Neal Gompa from comment #5)
> > 
> > Done and refreshed spec + srpm.
> 
> I am missing %doc docs/wget2.md. It is not yet installed.

It should be installed as the wget2.1 man page.

Comment 8 Petr Menšík 2021-10-10 18:33:03 UTC
Okay, that is generated from it. I would consider including also md file in doc, but that is definitely not blocker to solve. Maybe compress it, but include it in doc.

I think everything else is fine, giving review+. Thanks for immediate fixes.

Comment 9 Neal Gompa 2021-10-10 18:43:55 UTC
I've made the scm requests to create the repo now, thanks!

Comment 10 Tomas Hrcka 2021-10-11 07:29:08 UTC
(fedscm-admin):  The Pagure repository was created at https://src.fedoraproject.org/rpms/wget2

Comment 11 Fedora Update System 2021-10-11 12:47:01 UTC
FEDORA-2021-79ab5f7b47 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-79ab5f7b47

Comment 12 Fedora Update System 2021-10-11 12:47:01 UTC
FEDORA-2021-6eb77da035 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-6eb77da035

Comment 13 Fedora Update System 2021-10-11 21:33:13 UTC
FEDORA-2021-79ab5f7b47 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 14 Fedora Update System 2021-10-29 23:03:23 UTC
FEDORA-2021-6eb77da035 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.