Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 2021912

Summary: rust-sequoia-octopus-librnp: FTBFS with OpenSSL 3.0.0
Product: [Fedora] Fedora Reporter: Sahana Prasad <sahana>
Component: rust-sequoia-octopus-librnpAssignee: Fabio Valentini <decathorpe>
Status: CLOSED ERRATA QA Contact:
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: decathorpe, rust-sig
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: rust-sequoia-octopus-librnp-1.1.0-1.fc36 rust-sequoia-octopus-librnp-1.1.0-1.fc35 rust-sequoia-octopus-librnp-1.1.0-1.fc34 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-11-21 17:48:28 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 1990657    
Bug Blocks: 1825937, 1992484    

Description Sahana Prasad 2021-11-10 12:26:06 UTC
This bug is used to track the readiness of rust-sequoia-octopus-librnp with OpenSSL 3.0.0.

Currently the build fails to build with OpenSSL 3.0.0 with the following logs
Task info: https://koji.fedoraproject.org/koji/taskinfo?taskID=78020238

Kindly fix them to ensure this package builds with OpenSSL 3.0.0

You can treat the deprecated warnings not as errors if you want to continue to use deprecated functions, but it is encouraged to use the new APIs, and this migration could be done sooner than later.

To not treat deprecated warnings as errors, you may use
-Wno-error=deprecated-declarations

To port to new APIs, kindly refer to the OpenSSL upstream migration guide:
https://www.openssl.org/docs/manmaster/man7/migration_guide.html

Thank you

Comment 1 Fabio Valentini 2021-11-10 15:29:39 UTC
I *would like to* build this package, but I cannot due to a Rust compiler / LLVM toolchain issue.

Comment 2 Fedora Admin user for bugzilla script actions 2021-11-21 00:27:27 UTC
This package has changed maintainer in Fedora. Reassigning to the new maintainer of this component.

Comment 3 Fedora Update System 2021-11-21 17:48:28 UTC
FEDORA-2021-d30f9d81fe has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 4 Fedora Update System 2021-11-21 17:51:06 UTC
FEDORA-2021-1937205ae5 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-1937205ae5

Comment 5 Fedora Update System 2021-11-21 17:55:27 UTC
FEDORA-2021-b9e6038b3b has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-b9e6038b3b

Comment 6 Fedora Update System 2021-11-22 02:27:02 UTC
FEDORA-2021-1937205ae5 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-1937205ae5`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-1937205ae5

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Fedora Update System 2021-11-22 02:32:28 UTC
FEDORA-2021-b9e6038b3b has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-b9e6038b3b`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-b9e6038b3b

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 Fedora Update System 2021-11-24 09:14:16 UTC
FEDORA-2021-b9e6038b3b has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-b9e6038b3b

Comment 9 Fedora Update System 2021-11-24 09:58:02 UTC
FEDORA-2021-1937205ae5 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-1937205ae5

Comment 10 Fedora Update System 2021-11-25 23:16:17 UTC
FEDORA-2021-b9e6038b3b has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-b9e6038b3b

Comment 11 Fedora Update System 2021-11-26 02:15:44 UTC
FEDORA-2021-1937205ae5 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-1937205ae5

Comment 12 Fedora Update System 2021-11-26 03:04:36 UTC
FEDORA-2021-b9e6038b3b has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-b9e6038b3b`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-b9e6038b3b

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 13 Fedora Update System 2021-11-26 03:12:55 UTC
FEDORA-2021-1937205ae5 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-1937205ae5`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-1937205ae5

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 14 Fedora Update System 2021-11-27 01:10:25 UTC
FEDORA-2021-1937205ae5 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 15 Fedora Update System 2021-11-29 01:11:17 UTC
FEDORA-2021-b9e6038b3b has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.