Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 2022385

Summary: Replace the fbdev drivers with simpledrm and the DRM fbdev emulation layer
Product: [Fedora] Fedora Reporter: Ben Cotton <bcotton>
Component: Changes TrackingAssignee: Javier Martinez Canillas <javierm>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 36CC: bcotton, fmartine, javierm, ngompa13, pbrobinson, pwhalen
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2022-05-10 14:41:45 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 2067151    
Bug Blocks: 245418, 1269538, 1277927, 1298494, 1982279    

Description Ben Cotton 2021-11-11 14:33:25 UTC
This is a tracking bug for Change: Replace the fbdev drivers with simpledrm and the DRM fbdev emulation layer
For more details, see: https://fedoraproject.org/wiki/Changes/ReplaceFbdevDrivers

This change replaces the legacy Linux frame buffer device (fbdev) drivers that are still used in Fedora, with the latest simpledrm driver and the DRM fbdev emulation layer.

If you encounter a bug related to this Change, please do not comment here. Instead create a new bug and set it to block this bug.

Comment 1 Javier Martinez Canillas 2021-12-23 11:26:38 UTC
This change has been present in the Fedora kernel since https://gitlab.com/cki-project/kernel-ark/-/commit/53d2c01aef5aaad8b8bb54e4254f6ae671c76ee5

Comment 2 Javier Martinez Canillas 2021-12-23 11:44:17 UTC
*** Bug 1986222 has been marked as a duplicate of this bug. ***

Comment 3 Ben Cotton 2022-02-08 21:06:33 UTC
This bug appears to have been reported against 'rawhide' during the Fedora Linux 36 development cycle.
Changing version to 36.

Comment 4 Ben Cotton 2022-02-22 16:34:36 UTC
We have reached the 'Change complete (100% complete)' deadline in the Fedora Linux 36 release schedule.

At this time, all Changes should be fully complete. Indicate this by setting this tracking bug to ON_QA.

If you need to defer this Change to a subsequent release, please needinfo me.

Comment 5 Ben Cotton 2022-05-10 14:41:45 UTC
F36 was released today. If this Change did not land in the release, please notify bcotton as soon as possible.