Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 2049997

Summary: Please build libxml++ for EPEL 9
Product: [Fedora] Fedora EPEL Reporter: Robert Scheck <redhat-bugzilla>
Component: libxml++Assignee: Haïkel Guémar <karlthered>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: epel9CC: gary.buhrmaster, icon, karlthered, notting
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: libxml++-2.42.2-1.el9 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2022-12-08 01:11:13 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1914423, 2031776, 2144671    

Description Robert Scheck 2022-02-03 01:27:31 UTC
Description of problem:
Please build libxml++ for EPEL 9, because it's a dependency of the libffado package.

Version-Release number of selected component (if applicable):
libxml++-2.42.1-3.fc36

Actual results:
No libxml++ in EPEL 9.

Expected results:
libxml++-2.42.1-3.el9 - or better ;-)

Additional info:
Please let me know if you are not interested in maintaining the package on EPEL 9 branch.

Comment 1 Robert Scheck 2022-05-26 14:29:33 UTC
If you do not wish to maintain libxml++ in epel9, or do not think you will be able to do this in a timely manner, the EPEL Packagers SIG would be happy to be a co-maintainer of the package; please add the epel-packagers-sig group through https://src.fedoraproject.org/rpms/libxml++/addgroup and grant it commit access, or collaborator access on epel* branches.

Comment 2 Robert Scheck 2022-11-22 00:36:48 UTC
Will you be able to branch and build libxml++ in epel9? The EPEL Packagers SIG would be happy to be a co-maintainer if you do not wish to build it on epel9.

Comment 3 Robert Scheck 2022-11-29 06:27:20 UTC
Will you be able to branch and build libxml++ in epel9? The EPEL Packagers SIG would be happy to be a co-maintainer if you do not wish to build it on epel9.

Comment 4 Robert Scheck 2022-12-06 17:23:59 UTC
I've now filed https://pagure.io/releng/issue/11170 according to https://docs.fedoraproject.org/en-US/epel/epel-package-request/#epel_packagers_sig_members, because there was no response by the maintainer after three weeks and three attempts.

Comment 5 Fedora Update System 2022-12-07 20:32:11 UTC
FEDORA-EPEL-2022-c38f50dd9d has been submitted as an update to Fedora EPEL 9. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-c38f50dd9d

Comment 6 Fedora Update System 2022-12-08 01:11:13 UTC
FEDORA-EPEL-2022-c38f50dd9d has been pushed to the Fedora EPEL 9 stable repository.
If problem still persists, please make note of it in this bug report.