Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 2070657

Summary: F36FailsToInstall: GoldenCheetah
Product: [Fedora] Fedora Reporter: Miro Hrončok <mhroncok>
Component: GoldenCheetahAssignee: MartinKG <mgansser>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 36CC: fzatlouk, lruzicka, mgansser
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: AcceptedFreezeException
Fixed In Version: GoldenCheetah-3.6-0.15.20220413git98c22dc.fc36 GoldenCheetah-3.6-0.14.20220320gita0c2034.fc36 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2022-04-14 23:24:02 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1953786, 1992487    

Description Miro Hrončok 2022-03-31 15:52:00 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok).

Your package (GoldenCheetah) Fails To Install in Fedora 36:

can't install GoldenCheetah:
  - nothing provides libQt5Charts.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by GoldenCheetah-1:3.6-0.13.20220307git6b7121b.fc36.x86_64
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.


P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors. To reproduce, use the koji/local repo only, e.g. in mock:

    $ mock -r fedora-36-x86_64 --disablerepo='*' --enablerepo=local install GoldenCheetah


P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Fedora Update System 2022-04-01 09:30:44 UTC
FEDORA-2022-46864a4b9a has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-46864a4b9a

Comment 2 Fedora Update System 2022-04-02 01:25:09 UTC
FEDORA-2022-46864a4b9a has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-46864a4b9a`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-46864a4b9a

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 3 Miro Hrončok 2022-04-13 11:47:20 UTC
Let's not close this before it is stable please, otherwise you'll get new bugzilla again and agian.

Comment 4 Miro Hrončok 2022-04-13 11:47:25 UTC
*** Bug 2074985 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2022-04-13 13:49:54 UTC
FEDORA-2022-d38129347b has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-d38129347b

Comment 6 Fedora Update System 2022-04-13 19:49:21 UTC
FEDORA-2022-d38129347b has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-d38129347b`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-d38129347b

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Lukas Ruzicka 2022-04-14 07:39:39 UTC
Application can be installed with no issues.

Comment 8 František Zatloukal 2022-04-14 11:14:37 UTC
Discussed in ticket: https://pagure.io/fedora-qa/blocker-review/issue/754

The decision to classify this bug as an AcceptedFreezeException was made:

"We usually accept FTBFS/FTI fixes in during the Freeze."

Comment 9 Fedora Update System 2022-04-14 23:24:02 UTC
FEDORA-2022-d38129347b has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 10 Fedora Update System 2022-05-07 04:14:31 UTC
FEDORA-2022-46864a4b9a has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.