Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 2071304

Summary: qdigidoc4 crashes when signing a file
Product: [Fedora] Fedora Reporter: Ville-Pekka Vainio <vpvainio>
Component: qdigidocAssignee: Germano Massullo <germano.massullo>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 35CC: cserpentis, difiter23, germano.massullo, goanrauk
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: qdigidoc-4.2.12-2.fc36 qdigidoc-4.2.12-2.fc35 qdigidoc-4.2.12-2.fc37 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2022-10-08 17:33:42 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Ville-Pekka Vainio 2022-04-02 19:44:24 UTC
qdigidoc4 always crashes when signing a file. Luckily, it makes a valid .asice file before crashing.

I will not post a backtrace to prevent disclosing private information, but it crashes with
malloc(): unaligned tcache chunk detected

It should be this one: https://retrace.fedoraproject.org/faf/reports/381179/

Arch has some discussion about this issue: https://aur.archlinux.org/packages/qdigidoc4#comment-856965

If you take a look at this Arch diff https://aur.archlinux.org/cgit/aur.git/commit/?h=libdigidocpp&id=d8ba8f67f732de53e34a9accb5b0cebb9b85672e it points to commit https://github.com/open-eid/libdigidocpp/commit/42a8cfd834c10bdd206fe784a13217df222b1c8e and the changes in src/crypto/TS.cpp.

Version-Release number of selected component (if applicable):
qdigidoc-4.2.9-1.fc35.x86_64

Comment 1 Germano Massullo 2022-04-04 21:05:43 UTC
Before updating libdigidocpp to the lastest version, we need upstream developer to fix this
https://github.com/open-eid/libdigidocpp/issues/462

Comment 2 goanrauk 2022-05-25 09:48:19 UTC
I have a problem which I think is related to this one (the same error appears on the console). QDigiDoc4 will crash when trying to open .asice files which have been signed by other people.

Comment 3 Ville-Pekka Vainio 2022-07-25 18:18:27 UTC
There's now a new release of qdigidoc4 (https://github.com/open-eid/DigiDoc4-Client/releases/tag/v4.2.12) and libdigidocpp (the newest release that's been prepared today has not been tagged yet, so see https://github.com/open-eid/libdigidocpp/commits/master)

Comment 4 Oliver Jõgar 2022-08-30 18:55:02 UTC
It would be great to see some progress on this. I am unable to open .asice files from other people.

Comment 5 Germano Massullo 2022-08-30 21:36:03 UTC
Hello, I have just written to upstream developer because I don't know how to apply patch to qt-common/blob/master/CMakeLists.txt as explained at
https://github.com/open-eid/DigiDoc4-Client/wiki/DeveloperTips#building-in-sandboxed-environment
As soon I will receive a reply, I will update the package to the lastest version

Comment 6 Germano Massullo 2022-09-15 21:43:02 UTC
Can't release an update until [1] will be fixed
[1]: https://github.com/open-eid/DigiDoc4-Client/issues/1119

Comment 7 Germano Massullo 2022-10-05 17:22:11 UTC
To anyone that commented this bugreport and is **CURRENTLY** also a Fedora package maintainer. I need your help in fixing qdigidoc build failures. I contacted upstream developer and added patch1
https://src.fedoraproject.org/rpms/qdigidoc/blob/rawhide/f/qdigidoc.spec#_33
but the build still fails.
I am currently very busy, can I ask you if you have some time to check if you manage to fix it and please send a pull request?
Thank you and have a nice day!

Comment 8 Fedora Update System 2022-10-05 19:33:13 UTC
FEDORA-2022-f29121e528 has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2022-f29121e528

Comment 9 Fedora Update System 2022-10-05 19:33:15 UTC
FEDORA-2022-a8c65b1511 has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-a8c65b1511

Comment 10 Germano Massullo 2022-10-05 19:34:24 UTC
surprisingly a new build successfully built. So it must have been a problem of libraries. Please leave a karma feedback on previous URLs so that the update can go as soon as possible into stable repository

Comment 11 Fedora Update System 2022-10-05 19:57:14 UTC
FEDORA-2022-5ecb512d1f has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2022-5ecb512d1f

Comment 12 Fedora Update System 2022-10-06 14:17:32 UTC
FEDORA-2022-f29121e528 has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-f29121e528`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-f29121e528

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 13 Fedora Update System 2022-10-06 16:00:52 UTC
FEDORA-2022-a8c65b1511 has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-a8c65b1511`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-a8c65b1511

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 14 Fedora Update System 2022-10-06 16:45:54 UTC
FEDORA-2022-5ecb512d1f has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-5ecb512d1f`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-5ecb512d1f

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 15 Fedora Update System 2022-10-08 17:33:42 UTC
FEDORA-2022-a8c65b1511 has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 16 Fedora Update System 2022-10-14 12:58:34 UTC
FEDORA-2022-5ecb512d1f has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 17 Fedora Update System 2022-11-10 22:11:18 UTC
FEDORA-2022-f29121e528 has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.