Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 2104068

Summary: native libbluray depends on to be removed i686 java-openjdk packages
Product: [Fedora] Fedora Reporter: jiri vanek <jvanek>
Component: libblurayAssignee: Xavier Bachelot <xavier>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 37CC: dominik, java-maint-sig, jhuttana, jvanek, negativo17, pmikova, sgehwolf, xavier, zzambers
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: libbluray-1.3.2-1.fc38 libbluray-1.3.2-1.fc37 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2022-08-14 20:51:42 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 2083750    

Description jiri vanek 2022-07-05 14:47:48 UTC
Dear maintainer, we are going to drop i686 java packages in f37 - https://fedoraproject.org/wiki/Changes/Drop_i686_JDKs
your package (or maybe jsut some subpackage)  is directly depending on java and is native.

Please take care, and adapt  your package to exclude java on i686. For  your convenience, there was added macro %{java_arches}, including all arches java is available on,  which you can use to ifarch-out java specific features out in i686 (on non-java arches). Although for plain java package, the change is as simple as https://src.fedoraproject.org/rpms/maven/c/520942645bfd1e4721dacd536a6ccbf80495a8ae?branch=rawhide, you can not use it. The ExclusiveArch: %{java_arches} is not going to work for you, because your package is not simple java application, and also non-java world depends on it.

See exemplar PR: https://src.fedoraproject.org/rpms/graphviz/pull-request/9#request_diff
See more details eg in:: https://bugzilla.redhat.com/show_bug.cgi?id=2102298
See why in : https://pagure.io/fesco/issue/2772
Please read carefully proposal: https://fedoraproject.org/wiki/Changes/Drop_i686_JDKs
Please see tracking bug for most up to date informations: https://bugzilla.redhat.com/show_bug.cgi?id=2083750

I'm terribly sorry to report this bug so late in f37 lifecycle. If you can, please handle this with priority.

Comment 1 Ben Cotton 2022-08-09 13:20:28 UTC
This bug appears to have been reported against 'rawhide' during the Fedora Linux 37 development cycle.
Changing version to 37.

Comment 2 Fedora Update System 2022-08-14 20:48:39 UTC
FEDORA-2022-ef5319ad05 has been submitted as an update to Fedora 38. https://bodhi.fedoraproject.org/updates/FEDORA-2022-ef5319ad05

Comment 3 Fedora Update System 2022-08-14 20:51:01 UTC
FEDORA-2022-e6c2eef035 has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2022-e6c2eef035

Comment 4 Fedora Update System 2022-08-14 20:51:42 UTC
FEDORA-2022-ef5319ad05 has been pushed to the Fedora 38 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 5 Fedora Update System 2022-08-14 22:12:43 UTC
FEDORA-2022-e6c2eef035 has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.