Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 2132194

Summary: wireshark-4.0.1 is available
Product: [Fedora] Fedora Reporter: Upstream Release Monitoring <upstream-release-monitoring>
Component: wiresharkAssignee: Michal Ruprich <mruprich>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: alekcejk, denis, huzaifas, ken, lemenkov, mruprich, peter, rvokal, sergey.avseyev
Target Milestone: ---Keywords: FutureFeature, Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: wireshark-4.0.1-1.fc37 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2022-12-04 00:28:25 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Upstream Release Monitoring 2022-10-04 23:04:32 UTC
Releases retrieved: wireshark-4.0.0, 4.0.0
Upstream release that is considered latest: 4.0.0
Current version/release in rawhide: 3.6.8-1.fc38
URL: https://www.wireshark.org/

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/5137/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/wireshark

Comment 1 Upstream Release Monitoring 2022-10-04 23:04:38 UTC
Scratch build failed. Details below:

BuilderException: Build failed:
Command '['rpmbuild', '-D', '_sourcedir .', '-D', '_topdir .', '-bs', '/var/tmp/thn-x1mi5sqz/wireshark.spec']' returned non-zero exit status 1.

StdOut:
warning: line 86: It's not recommended to have unversioned Obsoletes: Obsoletes: wireshark-qt, wireshark-gtk
error: Bad source: ./wireshark-4.0.0.tar.xz: No such file or directory


Traceback:
  File "/usr/local/lib/python3.10/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
  File "/usr/local/lib/python3.10/site-packages/hotness/builders/koji.py", line 188, in build
    raise BuilderException(

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 2 Kenneth Topp 2022-10-10 15:00:30 UTC
i've created a PR for this, https://src.fedoraproject.org/rpms/wireshark/pull-request/10  also addresses the other issue #2128395

Comment 3 Upstream Release Monitoring 2022-10-26 18:26:43 UTC
Releases retrieved: wireshark-3.6.9, wireshark-4.0.1, 3.6.9, 4.0.1
Upstream release that is considered latest: 4.0.1
Current version/release in rawhide: 4.0.0-2.fc38
URL: https://www.wireshark.org/

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/5137/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/wireshark

Comment 4 Upstream Release Monitoring 2022-10-26 18:26:48 UTC
Scratch build failed. Details below:

BuilderException: Build failed:
Command '['rpmbuild', '-D', '_sourcedir .', '-D', '_topdir .', '-bs', '/var/tmp/thn-49oboxle/wireshark.spec']' returned non-zero exit status 1.

StdOut:
error: Bad source: ./wireshark-4.0.1.tar.xz: No such file or directory


Traceback:
  File "/usr/local/lib/python3.10/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
  File "/usr/local/lib/python3.10/site-packages/hotness/builders/koji.py", line 188, in build
    raise BuilderException(

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 5 nucleo 2022-10-26 20:31:36 UTC
Is it really necessary to switch to qt6 at this time?

Comment 6 Michal Ruprich 2022-10-27 06:05:30 UTC
Hi,

is this a rhetorical question or did you experience any problems with the new qt? If so, please file a bug so that I can take a look at it.

Comment 7 nucleo 2022-10-27 13:04:34 UTC
Hi,

This is not a real problem but Qt6 applications do not use yet system decoration theme such as Breeze theme in KDE when Wireshark built with Qt5.

Comment 8 Fedora Update System 2022-11-25 17:04:59 UTC
FEDORA-2022-cf9ae8e4ff has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2022-cf9ae8e4ff

Comment 9 Fedora Update System 2022-11-26 01:30:18 UTC
FEDORA-2022-cf9ae8e4ff has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-cf9ae8e4ff`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-cf9ae8e4ff

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Fedora Update System 2022-12-04 00:28:25 UTC
FEDORA-2022-cf9ae8e4ff has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.