Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 2132772

Summary: Editing a recurring event moves it forward in time
Product: [Fedora] Fedora Reporter: Kamil Páral <kparal>
Component: gnome-calendarAssignee: GNOME SIG Unassigned <gnome-sig>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 37CC: awilliam, gnome-sig, igor.raits, jan.public, klember, robatino, rstrode
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: AcceptedBlocker
Fixed In Version: gnome-calendar-43.0-6.fc37 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2022-10-19 07:23:39 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 2009539    

Description Kamil Páral 2022-10-06 15:35:11 UTC
This bug is just for blocker discussion. See the upstream description here:
https://gitlab.gnome.org/GNOME/gnome-calendar/-/issues/882

Proposing for a blocker discussion.

Comment 1 Adam Williamson 2022-10-10 09:01:48 UTC
+5 in https://pagure.io/fedora-qa/blocker-review/issue/960 , marking accepted.

Comment 2 Ray Strode [halfline] 2022-10-11 19:40:02 UTC
The eds client api is very foreign to me, but I posted what I think is a fix here: https://gitlab.gnome.org/GNOME/gnome-calendar/-/merge_requests/262

Comment 3 Fedora Update System 2022-10-11 20:23:36 UTC
FEDORA-2022-d687a7f331 has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2022-d687a7f331

Comment 4 Fedora Update System 2022-10-12 09:38:43 UTC
FEDORA-2022-d687a7f331 has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-d687a7f331`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-d687a7f331

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 5 Fedora Update System 2022-10-12 16:23:42 UTC
FEDORA-2022-d687a7f331 has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-d687a7f331`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-d687a7f331

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 6 Kamil Páral 2022-10-13 08:52:09 UTC
(In reply to Fedora Update System from comment #5)
> You can provide feedback for this update here:
> https://bodhi.fedoraproject.org/updates/FEDORA-2022-d687a7f331

This seems correctly fixed in gnome-calendar-43.0-5.fc37.x86_64. I found another problem though, I'll report it and link it in the upstream issue.

Comment 7 Adam Williamson 2022-10-17 22:04:13 UTC
Needs re-testing with the new build (43.0-6), so setting back to ON_QA.

Comment 8 Kamil Páral 2022-10-18 08:13:44 UTC
(In reply to Adam Williamson from comment #7)
> Needs re-testing with the new build (43.0-6), so setting back to ON_QA.

Seems to be fixed.

Comment 9 Fedora Update System 2022-10-18 12:40:52 UTC
FEDORA-2022-d687a7f331 has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-d687a7f331`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-d687a7f331

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Fedora Update System 2022-10-19 07:23:39 UTC
FEDORA-2022-d687a7f331 has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.