Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 2220236

Summary: F39FailsToInstall: python3-flask-security-too+babel, python3-flask-security-too+common, python3-flask-security-too+fsqla, python3-flask-security-too
Product: [Fedora] Fedora Reporter: Fedora Fails To Install <fti-bugs>
Component: python-flask-security-tooAssignee: Sandro Mani <manisandro>
Status: CLOSED RAWHIDE QA Contact:
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: code, manisandro
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2023-08-04 07:55:02 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 2220165, 2220231, 2220234, 2220235, 2220426, 2220523, 2226342    
Bug Blocks: 2168845, 2135404    

Description Fedora Fails To Install 2023-07-05 19:12:15 UTC
Hello,

Please note that this comment was generated automatically by https://pagure.io/releng/blob/main/f/scripts/ftbfs-fti/follow-policy.py
If you feel that this output has mistakes, please open an issue at https://pagure.io/releng/

Your package (python-flask-security-too) Fails To Install in Fedora 39:

can't install python3-flask-security-too+babel:
  - nothing provides python(abi) = 3.11 needed by python3-flask-security-too+babel-5.1.2-1.fc39.noarch
  - nothing provides python3.11dist(babel) >= 2.10 needed by python3-flask-security-too+babel-5.1.2-1.fc39.noarch
  
can't install python3-flask-security-too+common:
  - nothing provides python(abi) = 3.11 needed by python3-flask-security-too+common-5.1.2-1.fc39.noarch
  - nothing provides python3.11dist(bcrypt) >= 4.0.1 needed by python3-flask-security-too+common-5.1.2-1.fc39.noarch
  - nothing provides python3.11dist(bleach) >= 5 needed by python3-flask-security-too+common-5.1.2-1.fc39.noarch
  
can't install python3-flask-security-too+fsqla:
  - nothing provides python(abi) = 3.11 needed by python3-flask-security-too+fsqla-5.1.2-1.fc39.noarch
  - nothing provides python3.11dist(flask-sqlalchemy) >= 3.0.2 needed by python3-flask-security-too+fsqla-5.1.2-1.fc39.noarch
  - nothing provides python3.11dist(sqlalchemy) >= 1.4.35 needed by python3-flask-security-too+fsqla-5.1.2-1.fc39.noarch
  
can't install python3-flask-security-too:
  - nothing provides python(abi) = 3.11 needed by python3-flask-security-too-5.1.2-1.fc39.noarch
  - nothing provides python3.11dist(wtforms) >= 3 needed by python3-flask-security-too-5.1.2-1.fc39.noarch
  - nothing provides python3.11dist(email-validator) >= 1.1.1 needed by python3-flask-security-too-5.1.2-1.fc39.noarch
  - nothing provides python3.11dist(blinker) >= 1.4 needed by python3-flask-security-too-5.1.2-1.fc39.noarch
  - nothing provides python3.11dist(flask) >= 2.1 needed by python3-flask-security-too-5.1.2-1.fc39.noarch
  - nothing provides python3.11dist(flask-principal) >= 0.4 needed by python3-flask-security-too-5.1.2-1.fc39.noarch
  - nothing provides python3.11dist(flask-wtf) >= 1 needed by python3-flask-security-too-5.1.2-1.fc39.noarch
  - nothing provides python3.11dist(itsdangerous) >= 2.1 needed by python3-flask-security-too-5.1.2-1.fc39.noarch
  - nothing provides python3.11dist(passlib) >= 1.7.4 needed by python3-flask-security-too-5.1.2-1.fc39.noarch
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.


P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors. To reproduce, use the koji/local repo only, e.g. in mock:

    $ mock -r fedora-39-x86_64 --config-opts mirrored=False install python3-flask-security-too+babel python3-flask-security-too+common python3-flask-security-too+fsqla python3-flask-security-too


P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Ben Beasley 2023-07-06 04:24:36 UTC
$ fedpkg mockbuild --enablerepo=local
Error:
 Problem 1: package python3-check-manifest-0.48-3.fc37.noarch from fedora requires python(abi) = 3.11, but none of the providers can be installed
  - package python3-devel-3.12.0~b3-2.fc39.x86_64 from @System conflicts with python3 < 3.12.0~b3-2.fc39 provided by python3-3.11.4-1.fc39.i686 from fedora
  - package python3-devel-3.12.0~b3-2.fc39.x86_64 from @System conflicts with python3 < 3.12.0~b3-2.fc39 provided by python3-3.11.4-1.fc39.x86_64 from fedora
  - cannot install the best candidate for the job
 Problem 2: package python3-flask-babel-2.0.0-5.fc38.noarch from fedora requires python(abi) = 3.11, but none of the providers can be installed
  - package python3-devel-3.12.0~b3-2.fc39.x86_64 from @System conflicts with python3 < 3.12.0~b3-2.fc39 provided by python3-3.11.4-1.fc39.i686 from fedora
  - package python3-devel-3.12.0~b3-2.fc39.x86_64 from @System conflicts with python3 < 3.12.0~b3-2.fc39 provided by python3-3.11.4-1.fc39.x86_64 from fedora
  - cannot install the best candidate for the job
 Problem 3: cannot install both python3-werkzeug-2.2.3-2.fc39.noarch from local and python3-werkzeug-2.2.3-1.fc39.noarch from fedora
  - package python3-flask-login-0.6.2-2.fc39.noarch from fedora requires python3.11dist(werkzeug) >= 1.0.1, but none of the providers can be installed
  - cannot install the best candidate for the job
 Problem 4: cannot install both python3-flask-1:2.2.5-2.fc39.noarch from local and python3-flask-1:2.2.5-1.fc39.noarch from fedora
  - package python3-flask-principal-0.4.0-34.fc39.noarch from local requires python3.12dist(flask), but none of the providers can be installed
  - package python3-flask-mailman-0.3.0-5.fc39.noarch from fedora requires python3.11dist(flask) >= 1, but none of the providers can be installed
  - cannot install the best candidate for the job
 Problem 5: package python3-sqlalchemy-utils-0.41.1-1.fc39.noarch from fedora requires python3.11dist(sqlalchemy) >= 1.3, but none of the providers can be installed
  - cannot install both python3-sqlalchemy-1.4.49~~20230703cd56e87-1.fc39.x86_64 from local and python3-sqlalchemy-1.4.48-1.fc39.x86_64 from fedora
  - package python3-sqlalchemy1.3-1.3.24-7.fc38.x86_64 from fedora conflicts with python3-sqlalchemy provided by python3-sqlalchemy-1.4.49~~20230703cd56e87-1.fc39.x86_64 from local
  - package python3-flask-sqlalchemy-3.0.3-2.fc39.noarch from local requires python3.12dist(sqlalchemy) >= 1.4.18, but none of the providers can be installed
  - cannot install the best candidate for the job
 Problem 6: package python3-pymongo-gridfs-4.2.0-3.fc39.x86_64 from local requires python(abi) = 3.12, but none of the providers can be installed
  - cannot install both python3-3.11.4-1.fc39.x86_64 from fedora and python3-3.12.0~b3-2.fc39.x86_64 from @System
  - cannot install both python3-3.12.0~b3-2.fc39.x86_64 from local and python3-3.11.4-1.fc39.x86_64 from fedora
  - python3-3.11.4-1.fc39.i686 from fedora  does not belong to a distupgrade repository
  - package python3-snowballstemmer-2.2.0-5.fc38.noarch from fedora requires python(abi) = 3.11, but none of the providers can be installed
  - package python3-pydocstyle-6.3.0-1.fc39.noarch from fedora requires python3.11dist(snowballstemmer) >= 2.2, but none of the providers can be installed
  - cannot install the best candidate for the job
  - package python3-mongoengine-0.27.0-2.fc39.noarch from local requires python3-pymongo-gridfs, but none of the providers can be installed
  - package python3-pymongo-gridfs-4.2.0-2.fc38.x86_64 from fedora requires python3-pymongo(x86-64) = 4.2.0-2.fc38, but none of the providers can be installed
  - cannot install both python3-pymongo-4.2.0-3.fc39.x86_64 from local and python3-pymongo-4.2.0-2.fc38.x86_64 from fedora
  - package python3-mongoengine-0.27.0-2.fc39.noarch from local requires (python3.12dist(pymongo) < 5~~ with python3.12dist(pymongo) >= 3.4), but none of the providers can be installed

I have captured most or all of the above in “Depends on” relationships with other bugs.

Comment 2 Fedora Fails To Install 2023-07-13 11:52:22 UTC
Hello,

Please note that this comment was generated automatically by https://pagure.io/releng/blob/main/f/scripts/ftbfs-fti/follow-policy.py
If you feel that this output has mistakes, please open an issue at https://pagure.io/releng/

This package fails to install and maintainers are advised to take one of the following actions:

 - Fix this bug and close this bugzilla once the update makes it to the repository.
   (The same script that posted this comment will eventually close this bugzilla
   when the fixed package reaches the repository, so you don't have to worry about it.)

or

 - Move this bug to ASSIGNED if you plan on fixing this, but simply haven't done so yet.

or

 - Orphan the package if you no longer plan to maintain it.


If you do not take one of these actions, the process at https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs will continue.
This package may be orphaned in 7+ weeks.
This is the first reminder (step 3) from the policy.

Don't hesitate to ask for help on devel.org if you are unsure how to fix this bug.