Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 2220496

Summary: F39FailsToInstall: Multiple packages built from python-sentry-sdk
Product: [Fedora] Fedora Reporter: Fedora Fails To Install <fti-bugs>
Component: python-sentry-sdkAssignee: Roman Inflianskas <rominf>
Status: CLOSED ERRATA QA Contact:
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: code, italo.garcia+fedora, paul.wouters, rj.layco, rominf
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: python-sentry-sdk-1.28.0-1.fc39 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2023-07-13 09:03:55 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 2220146, 2220234, 2220300, 2220379    
Bug Blocks: 2168845, 2135404    

Description Fedora Fails To Install 2023-07-05 19:20:52 UTC
Hello,

Please note that this comment was generated automatically by https://pagure.io/releng/blob/main/f/scripts/ftbfs-fti/follow-policy.py
If you feel that this output has mistakes, please open an issue at https://pagure.io/releng/

Your package (python-sentry-sdk) Fails To Install in Fedora 39:

can't install python3-sentry-sdk+aiohttp:
  - nothing provides python(abi) = 3.11 needed by python3-sentry-sdk+aiohttp-1.27.0-1.fc39.noarch
  - nothing provides python3.11dist(aiohttp) >= 3.5 needed by python3-sentry-sdk+aiohttp-1.27.0-1.fc39.noarch
  
can't install python3-sentry-sdk+bottle:
  - nothing provides python(abi) = 3.11 needed by python3-sentry-sdk+bottle-1.27.0-1.fc39.noarch
  - nothing provides python3.11dist(bottle) >= 0.12.13 needed by python3-sentry-sdk+bottle-1.27.0-1.fc39.noarch
  
can't install python3-sentry-sdk+celery:
  - nothing provides python(abi) = 3.11 needed by python3-sentry-sdk+celery-1.27.0-1.fc39.noarch
  
can't install python3-sentry-sdk+django:
  - nothing provides python(abi) = 3.11 needed by python3-sentry-sdk+django-1.27.0-1.fc39.noarch
  
can't install python3-sentry-sdk+fastapi:
  - nothing provides python(abi) = 3.11 needed by python3-sentry-sdk+fastapi-1.27.0-1.fc39.noarch
  
can't install python3-sentry-sdk+flask:
  - nothing provides python3.11dist(blinker) >= 1.1 needed by python3-sentry-sdk+flask-1.27.0-1.fc39.noarch
  - nothing provides python3.11dist(flask) >= 0.11 needed by python3-sentry-sdk+flask-1.27.0-1.fc39.noarch
  - nothing provides python3.11dist(markupsafe) needed by python3-sentry-sdk+flask-1.27.0-1.fc39.noarch
  - nothing provides python(abi) = 3.11 needed by python3-sentry-sdk+flask-1.27.0-1.fc39.noarch
  
can't install python3-sentry-sdk+grpcio:
  - nothing provides python(abi) = 3.11 needed by python3-sentry-sdk+grpcio-1.27.0-1.fc39.noarch
  - nothing provides python3.11dist(grpcio) >= 1.21.1 needed by python3-sentry-sdk+grpcio-1.27.0-1.fc39.noarch
  
can't install python3-sentry-sdk+httpx:
  - nothing provides python(abi) = 3.11 needed by python3-sentry-sdk+httpx-1.27.0-1.fc39.noarch
  - nothing provides python3.11dist(httpx) >= 0.16 needed by python3-sentry-sdk+httpx-1.27.0-1.fc39.noarch
  
can't install python3-sentry-sdk+opentelemetry:
  - nothing provides python(abi) = 3.11 needed by python3-sentry-sdk+opentelemetry-1.27.0-1.fc39.noarch
  
can't install python3-sentry-sdk+pure_eval:
  - nothing provides python3.11dist(asttokens) needed by python3-sentry-sdk+pure_eval-1.27.0-1.fc39.noarch
  - nothing provides python3.11dist(executing) needed by python3-sentry-sdk+pure_eval-1.27.0-1.fc39.noarch
  - nothing provides python3.11dist(pure-eval) needed by python3-sentry-sdk+pure_eval-1.27.0-1.fc39.noarch
  - nothing provides python(abi) = 3.11 needed by python3-sentry-sdk+pure_eval-1.27.0-1.fc39.noarch
  
can't install python3-sentry-sdk+pymongo:
  - nothing provides python(abi) = 3.11 needed by python3-sentry-sdk+pymongo-1.27.0-1.fc39.noarch
  - nothing provides python3.11dist(pymongo) >= 3.1 needed by python3-sentry-sdk+pymongo-1.27.0-1.fc39.noarch
  
can't install python3-sentry-sdk+rq:
  - nothing provides python(abi) = 3.11 needed by python3-sentry-sdk+rq-1.27.0-1.fc39.noarch
  - nothing provides python3.11dist(rq) >= 0.6 needed by python3-sentry-sdk+rq-1.27.0-1.fc39.noarch
  
can't install python3-sentry-sdk+sqlalchemy:
  - nothing provides python(abi) = 3.11 needed by python3-sentry-sdk+sqlalchemy-1.27.0-1.fc39.noarch
  - nothing provides python3.11dist(sqlalchemy) >= 1.2 needed by python3-sentry-sdk+sqlalchemy-1.27.0-1.fc39.noarch
  
can't install python3-sentry-sdk+starlette:
  - nothing provides python(abi) = 3.11 needed by python3-sentry-sdk+starlette-1.27.0-1.fc39.noarch
  - nothing provides python3.11dist(starlette) >= 0.19.1 needed by python3-sentry-sdk+starlette-1.27.0-1.fc39.noarch
  
can't install python3-sentry-sdk+tornado:
  - nothing provides python(abi) = 3.11 needed by python3-sentry-sdk+tornado-1.27.0-1.fc39.noarch
  - nothing provides python3.11dist(tornado) >= 5 needed by python3-sentry-sdk+tornado-1.27.0-1.fc39.noarch
  
can't install python3-sentry-sdk:
  - nothing provides python3.11dist(certifi) needed by python3-sentry-sdk-1.27.0-1.fc39.noarch
  - nothing provides python(abi) = 3.11 needed by python3-sentry-sdk-1.27.0-1.fc39.noarch
  - nothing provides python3.11dist(urllib3) >= 1.26.11 needed by python3-sentry-sdk-1.27.0-1.fc39.noarch
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.


P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors. To reproduce, use the koji/local repo only, e.g. in mock:

    $ mock -r fedora-39-x86_64 --config-opts mirrored=False install python3-sentry-sdk+aiohttp python3-sentry-sdk+bottle python3-sentry-sdk+celery python3-sentry-sdk+django python3-sentry-sdk+fastapi python3-sentry-sdk+flask python3-sentry-sdk+grpcio python3-sentry-sdk+httpx python3-sentry-sdk+opentelemetry python3-sentry-sdk+pure_eval python3-sentry-sdk+pymongo python3-sentry-sdk+rq python3-sentry-sdk+sqlalchemy python3-sentry-sdk+starlette python3-sentry-sdk+tornado python3-sentry-sdk


P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Ben Beasley 2023-07-06 04:41:02 UTC
Fixed and worked around some dependency issues to get FastAPI working on Python 3.12. Now:

$ fedpkg mockbuild --enablerepo=local

Error: 
 Problem 1: package python3-celery-5.3.1-1.fc39.noarch from fedora requires python(abi) = 3.11, but none of the providers can be installed
  - package python3-devel-3.12.0~b3-2.fc39.x86_64 from local conflicts with python3 < 3.12.0~b3-2.fc39 provided by python3-3.11.4-1.fc39.i686 from fedora
  - package python3-devel-3.12.0~b3-2.fc39.x86_64 from local conflicts with python3 < 3.12.0~b3-2.fc39 provided by python3-3.11.4-1.fc39.x86_64 from fedora
  - cannot install the best candidate for the job
 Problem 2: package python3-flask-login-0.6.2-2.fc39.noarch from fedora requires python3.11dist(flask) >= 1.0.4, but none of the providers can be installed
  - cannot install both python3-flask-1:2.2.5-2.fc39.noarch from local and python3-flask-1:2.2.5-1.fc39.noarch from fedora
  - cannot install the best candidate for the job
 Problem 3: package python3-opentelemetry-api-1.18.0-2.fc39.noarch from fedora requires python3.11dist(setuptools) >= 16, but none of the providers can be installed
  - cannot install both python3-setuptools-67.7.2-5.fc39.noarch from local and python3-setuptools-67.7.2-2.fc39.noarch from fedora
  - package python3-opentelemetry-distro-1:0.39~b0-16.fc39.noarch from fedora requires (python3.11dist(opentelemetry-api) >= 1.12 with python3.11dist(opentelemetry-api) < 2), but none of the providers can be installed
  - package python3-gevent-22.10.2-3.fc39.x86_64 from local requires python3.12dist(setuptools), but none of the providers can be installed
  - cannot install the best candidate for the job

Comment 2 Ben Beasley 2023-07-13 05:01:40 UTC
$ fedpkg mockbuild --enablerepo=local

=================================== FAILURES ===================================
_______________________ test_breadcrumb_extra_scrubbing ________________________
tests/test_scrubber.py:103: in test_breadcrumb_extra_scrubbing
    assert event["breadcrumbs"]["values"][0]["data"] == {
E   AssertionError: assert {'foo': 42, '...skName': None} == {'foo': 42, '... '[Filtered]'}
E     Omitting 2 identical items, use -vv to show
E     Left contains 1 more item:
E     {'taskName': None}
E     Use -v to get more diff
------------------------------ Captured log call -------------------------------
INFO     tests.test_scrubber:test_scrubber.py:95 bread
CRITICAL tests.test_scrubber:test_scrubber.py:96 whoops
___________________________ test_logging_extra_data ____________________________
tests/integrations/logging/test_logging.py:64: in test_logging_extra_data
    assert event["extra"] == {"bar": 69}
E   AssertionError: assert {'bar': 69, 'taskName': None} == {'bar': 69}
E     Omitting 1 identical items, use -vv to show
E     Left contains 1 more item:
E     {'taskName': None}
E     Use -v to get more diff
------------------------------ Captured log call -------------------------------
INFO     test_logging:test_logging.py:58 bread
CRITICAL test_logging:test_logging.py:59 lol
_____________________ test_logging_extra_data_integer_keys _____________________
tests/integrations/logging/test_logging.py:79: in test_logging_extra_data_integer_keys
    assert event["extra"] == {"1": 1}
E   AssertionError: assert {'1': 1, 'taskName': None} == {'1': 1}
E     Omitting 1 identical items, use -vv to show
E     Left contains 1 more item:  
E     {'taskName': None}
E     Use -v to get more diff
------------------------------ Captured log call -------------------------------
CRITICAL test_logging:test_logging.py:75 integer in extra keys
________________________ test_logging_captured_warnings ________________________
tests/integrations/logging/test_logging.py:194: in test_logging_captured_warnings
    assert len(events) == 2
E   AssertionError: assert 4 == 2 
E    +  where 4 = len([{'breadcrumbs': {'values': []}, 'contexts': {'trace': {'parent_span_id': None, 'span_id': '951db6cb792b6ac2', 'trace_...fc89639000b4441c9fc3c1de90f74734'}}, 'environment': 'production', 'event_id': '4634c0a5fe874924b478908aaef93e31', ...}])
------------------------------ Captured log call -------------------------------
WARNING  py.warnings:warnings.py:109 /builddir/build/BUILD/sentry-python-1.27.0/tests/integrations/logging/test_logging.py:188: UserWarning: first
  warnings.warn("first")

WARNING  py.warnings:warnings.py:109 /builddir/build/BUILD/sentry-python-1.27.0/sentry_sdk/client.py:261: DeprecationWarning: datetime.utcnow() is deprecated and scheduled for removal in a future version. Use timezone-aware objects to represent datetimes in UTC: datetime.now(datetime.UTC).
  event["timestamp"] = datetime.utcnow()

WARNING  py.warnings:warnings.py:109 /builddir/build/BUILD/sentry-python-1.27.0/sentry_sdk/integrations/logging.py:282: DeprecationWarning: datetime.utcfromtimestamp() is deprecated and scheduled for removal in a future version. Use timezone-aware objects to represent datetimes in UTC: datetime.fromtimestamp(timestamp, datetime.UTC).
  "timestamp": datetime.datetime.utcfromtimestamp(record.created),

WARNING  py.warnings:warnings.py:109 /builddir/build/BUILD/sentry-python-1.27.0/tests/integrations/logging/test_logging.py:189: UserWarning: second
  warnings.warn("second")
=============================== warnings summary ===============================

(massive spew of warnings)

============================= slowest 5 durations ==============================
2.75s call     tests/test_client.py::test_atexit[20]
2.35s call     tests/integrations/celery/test_celery.py::test_no_stackoverflows
1.76s call     tests/test_client.py::test_atexit[10]
0.77s call     tests/integrations/stdlib/test_subprocess.py::test_subprocess_basic[False-None-as_list-False]
0.77s call     tests/integrations/stdlib/test_subprocess.py::test_subprocess_basic[True-env_mapping1-as_list-False]
=========================== short test summary info ============================
FAILED tests/test_scrubber.py::test_breadcrumb_extra_scrubbing - AssertionErr...
FAILED tests/integrations/logging/test_logging.py::test_logging_extra_data - ...
FAILED tests/integrations/logging/test_logging.py::test_logging_extra_data_integer_keys
FAILED tests/integrations/logging/test_logging.py::test_logging_captured_warnings
== 4 failed, 942 passed, 18 skipped, 43 deselected, 27496 warnings in 39.58s ===

Comment 3 Ben Beasley 2023-07-13 05:02:18 UTC
Confirmed FastAPI 0.100.0 (https://src.fedoraproject.org/rpms/python-fastapi/pull-request/7) will not introduce additional regressions.

Comment 4 Roman Inflianskas 2023-07-13 08:12:10 UTC
The reason for first three tests breakage is: https://github.com/python/cpython/blob/4b4a5b70aa8d47b1e2a0582b741c31b786da762a/Misc/NEWS.d/3.12.0a1.rst?plain=1#L3660-L3661

I'm working on this.

Comment 5 Fedora Update System 2023-07-13 09:01:48 UTC
FEDORA-2023-b7413dd384 has been submitted as an update to Fedora 39. https://bodhi.fedoraproject.org/updates/FEDORA-2023-b7413dd384

Comment 6 Fedora Update System 2023-07-13 09:03:55 UTC
FEDORA-2023-b7413dd384 has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.