Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 430177

Summary: clamd.d/amavisd.conf configuration directives require boolean arguments
Product: [Fedora] Fedora EPEL Reporter: Ray Van Dolson <rayvd>
Component: amavisd-newAssignee: Juan Orti <jorti>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: el5CC: jlquinn, johan-fedora, jorti, perl-devel
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: ActualBug
Fixed In Version: amavisd-new-2.5.2-3.el5 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-11-29 03:24:00 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Attachments:
Description Flags
Patch to fix the problems. none

Description Ray Van Dolson 2008-01-25 00:48:04 UTC
After installing amavisd-new-2.4.5-1.el5 from epel-testing I get the following
when running service clamd.amavisd start:

# service clamd.amavisd start
Starting clamd.amavisd: ERROR: Parse error at line 2: Option LogSyslog requires
boolean argument.
ERROR: Can't open/parse the config file /etc/clamd.d/amavisd.conf
                                                           [FAILED]

Turns out FixStaleSocket also requires a boolean argument.

I appended a 'yes' to both of these configuration directives and everything is
working fine now.

This is in tandem with clamav-server-0.92-4.1.el5 from epel.

Comment 1 Ray Van Dolson 2008-01-25 00:49:25 UTC
Note: You may want to check this with EL4 as well.  I don't have one handy to
test with at the moment.

Comment 2 Ray Van Dolson 2008-02-29 07:28:29 UTC
Ping?

Comment 3 Steven Pritchard 2008-03-01 19:45:24 UTC
Sorry for the delay.  This will be fixed as soon as I am able to upgrade the
amavisd-new in EPEL to something current.  The last time I worked on this, we
were still missing some dependencies.

Comment 4 Johan Kok 2008-07-08 14:50:27 UTC
Steven, is this issue still present?

Comment 5 jlquinn 2008-12-07 05:13:54 UTC
Yes, it's present.  I just installed amavisd-new again and see the same problem in /etc/clamd.d/amavisd.conf

Comment 6 Michael Arnold 2010-04-03 16:33:15 UTC
Created attachment 404312 [details]
Patch to fix the problems.

Attached is a patch to fix the problems.

Comment 7 Johan Kok 2011-06-09 05:31:08 UTC
*** Bug 459954 has been marked as a duplicate of this bug. ***

Comment 8 Fedora Update System 2014-08-07 09:49:06 UTC
amavisd-new-2.5.2-3.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/amavisd-new-2.5.2-3.el5

Comment 9 Fedora Update System 2014-08-08 00:40:59 UTC
Package amavisd-new-2.5.2-3.el5:
* should fix your issue,
* was pushed to the Fedora EPEL 5 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing amavisd-new-2.5.2-3.el5'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-2152/amavisd-new-2.5.2-3.el5
then log in and leave karma (feedback).

Comment 10 Fedora Update System 2015-11-29 03:23:57 UTC
amavisd-new-2.5.2-3.el5 has been pushed to the Fedora EPEL 5 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Red Hat Bugzilla 2023-09-14 01:11:53 UTC
The needinfo request[s] on this closed bug have been removed as they have been unresolved for 1000 days