Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 459954

Summary: Default clamd conf file is broken
Product: [Fedora] Fedora EPEL Reporter: jlquinn
Component: amavisd-newAssignee: Steven Pritchard <steve>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: el5CC: johan-fedora, mastahnke, perl-devel
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: ActualBug
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-06-09 05:31:08 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description jlquinn 2008-08-25 05:52:44 UTC
Description of problem:

/etc/clam.d/amavisd.conf has syntax errors that prevent 

Version-Release number of selected component (if applicable):

amavisd-new-2.4.5-1.el5

How reproducible:

[root@mail1 ~]# service clamd.amavisd start
Starting clamd.amavisd: ERROR: Parse error at line 2: Option LogSyslog requires boolean argument.
ERROR: Can't open/parse the config file /etc/clamd.d/amavisd.conf
                                                           [FAILED]

After fixing this option to be:

LogSyslog yes

then

[root@mail1 amavisd-new-2.4.5]# service clamd.amavisd start
Starting clamd.amavisd: ERROR: Parse error at line 14: Option FixStaleSocket requires boolean argument.
ERROR: Can't open/parse the config file /etc/clamd.d/amavisd.conf
                                                           [FAILED]

Fixing this to be:

FixStaleSocket yes

allows clamd to start correctly.


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Johan Kok 2011-06-09 05:31:08 UTC
Thank you for the bug report. This particular bug has already been reported into our bug tracking system, but please feel free to report any further bugs you find.

*** This bug has been marked as a duplicate of bug 430177 ***