Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 514309

Summary: virt-df2 blocks update of libguestfs
Product: [Fedora] Fedora Reporter: John Guthrie <mathguthrie>
Component: virt-dfAssignee: Richard W.M. Jones <rjones>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 11CC: fedora-ocaml-list, rjones, virt-maint
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 1.0.68-5.el5 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-08-18 00:23:15 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description John Guthrie 2009-07-28 19:34:02 UTC
Description of problem:
The most recent update of libguestfs is not able to be installed if virt-df2 is installed.

Version-Release number of selected component (if applicable):
1.0.58-2.fc11

How reproducible:
Every time

Steps to Reproduce:
1.Install libguestfs-1.0.58-2.fc11 and virt-df2-1.0.58-2.fc11
2.Run "yum update"
3.
  
Actual results:
I get the following output:

# yum update
Loaded plugins: aliases, changelog, downloadonly, fastestmirror, filter-data,
              : keys, list-data, presto, refresh-packagekit, rpm-warm-cache,
              : security
Loading mirror speeds from cached hostfile
 * fedora: mirrors.med.harvard.edu
 * updates: mirror.steadfast.net
Skipping filters plugin, no data
Skipping security plugin, no data
Setting up Update Process
Resolving Dependencies
Skipping filters plugin, no data
Skipping security plugin, no data
--> Running transaction check
---> Package guestfish.i586 1:1.0.64-2.fc11 set to be updated
--> Processing Dependency: libguestfs = 1.0.58-2.fc11 for package: virt-df2-1.0.58-2.fc11.i586
---> Package libguestfs.i586 1:1.0.64-2.fc11 set to be updated
--> Processing Dependency: chntpw >= 0.99.6-8 for package: 1:libguestfs-1.0.64-2.fc11.i586
---> Package perl-libguestfs.i586 1:1.0.64-2.fc11 set to be updated
--> Processing Dependency: perl(Locale::TextDomain) for package: 1:perl-libguestfs-1.0.64-2.fc11.i586
---> Package virt-inspector.i586 1:1.0.64-2.fc11 set to be updated
--> Running transaction check
---> Package chntpw.i586 0:0.99.6-9.fc11 set to be updated
--> Processing Dependency: libguestfs = 1.0.58-2.fc11 for package: virt-df2-1.0.58-2.fc11.i586
---> Package perl-libintl.i586 0:1.16-9.fc11 set to be updated
--> Finished Dependency Resolution
virt-df2-1.0.58-2.fc11.i586 from installed has depsolving problems
  --> Missing Dependency: libguestfs = 1.0.58-2.fc11 is needed by package virt-df2-1.0.58-2.fc11.i586 (installed)
Error: Missing Dependency: libguestfs = 1.0.58-2.fc11 is needed by package virt-df2-1.0.58-2.fc11.i586 (installed)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest

Expected results:
I would expect libguestfs and possibly virt-df2 as well to be updated.

Additional info:

Comment 1 Richard W.M. Jones 2009-07-28 20:23:47 UTC
We can add an Obsoletes for this in the next release, but
note that the earlier version shouldn't have ever left
updates-testing.

To work around this you just have to remove
virt-df2 before trying to upgrade libguestfs.

Comment 2 Fedora Update System 2009-07-29 17:00:44 UTC
libguestfs-1.0.65-2.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/libguestfs-1.0.65-2.el5

Comment 3 Fedora Update System 2009-07-29 22:56:58 UTC
libguestfs-1.0.65-2.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libguestfs'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/EL-5/FEDORA-EPEL-2009-0149

Comment 4 Fedora Update System 2009-08-05 03:22:41 UTC
libguestfs-1.0.65-2.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libguestfs'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/EL-5/FEDORA-EPEL-2009-0149

Comment 5 Fedora Update System 2009-08-07 08:34:04 UTC
libguestfs-1.0.66-4.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/libguestfs-1.0.66-4.el5

Comment 6 Fedora Update System 2009-08-10 20:32:38 UTC
libguestfs-1.0.66-4.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libguestfs'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/EL-5/FEDORA-EPEL-2009-0249

Comment 7 Fedora Update System 2009-08-14 09:13:47 UTC
libguestfs-1.0.67-1.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/libguestfs-1.0.67-1.el5

Comment 8 Fedora Update System 2009-08-18 00:22:44 UTC
libguestfs-1.0.65-2.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2009-08-19 21:55:16 UTC
libguestfs-1.0.68-5.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/libguestfs-1.0.68-5.el5

Comment 10 Fedora Update System 2009-09-08 22:59:25 UTC
libguestfs-1.0.68-5.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.