Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 588364

Summary: Can't install rubygem-hoe
Product: [Fedora] Fedora EPEL Reporter: Lubomir Rintel <lkundrak>
Component: rubygem-hoeAssignee: Michael Stahnke <mastahnke>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: el5CC: mastahnke, mtasaka, tremble, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-09-22 10:57:17 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 589696, 589801    
Bug Blocks:    

Description Lubomir Rintel 2010-05-03 14:59:21 UTC
Description of problem:

rubygem-hoe-2.5.0-2.el5.noarch from epel has depsolving problems
  --> Missing Dependency: rubygem(minitest) >= 1.4.2 is needed by package rubygem-hoe-2.5.0-2.el5.noarch (epel)
rubygem-hoe-2.5.0-2.el5.noarch from epel has depsolving problems
  --> Missing Dependency: rubygem(gemcutter) >= 0.2.1 is needed by package rubygem-hoe-2.5.0-2.el5.noarch (epel)
rubygem-hoe-2.5.0-2.el5.noarch from epel has depsolving problems
  --> Missing Dependency: rubygem(rubyforge) >= 2.0.3 is needed by package rubygem-hoe-2.5.0-2.el5.noarch (epel)

Comment 1 Michael Stahnke 2010-05-04 00:28:50 UTC
Hmm.  My fault for missing some deps.  This works on my test system, but I realized I had built some additional packages in preparation for Sinatra stuff. I have requested the packages for rubygem-minitest and rubygem-gemcutter.  rubygem-rubyforge is already available in EPEL. I will keep you posted on status.

Comment 2 Lubomir Rintel 2010-05-05 15:53:56 UTC
Michael, your fault is dragging in a new major version of package (apart from dragging in a ton of new dependencies).

Please do not do this sort of thing in EPEL, push bugfixes only and leave this for fedora.

Thank you for quick reaction though.

Comment 3 Michael Stahnke 2010-05-05 19:11:24 UTC
Putting in new version is not a problem in EPEL, if you maintain compatibility. 

Somehow, I just missed these two deps and am still figuring that part out.  (That system has been re-imaged since then.)   Normally I start with maintaining these packages for my day job and then move them to EPEL once I've been using them a while.  In this case, there is obviously some variable I missed on my work systems vs. a raw EPEL repo.  I am trying to fix it and have requested branches for minitest and gemcutter.

Comment 4 Mark Chappell 2010-09-22 10:57:17 UTC
rubygem-hoe now installs fine, closing off this bug