Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 671257

Summary: compizconfig-backend-gconf 0.9.2.2-0.1.git86d949fad4 not built with $RPM_OPT_FLAGS
Product: [Fedora] Fedora Reporter: Ville Skyttä <ville.skytta>
Component: compizAssignee: Adam Williamson <awilliam>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: high    
Version: rawhideCC: adel.gadllah, awilliam, kagesenshi.87, mcepl, mcepl
Target Milestone: ---Keywords: Regression, Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-01-24 04:25:20 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 496968    

Description Ville Skyttä 2011-01-20 21:36:14 UTC
See gcc commands in the build log, and note that -debuginfo contains no sources.

This looks like a regression, 0.8.4-4 seems to have been built with $RPM_OPT_FLAGS.
http://kojipkgs.fedoraproject.org/packages/compizconfig-backend-gconf/0.8.4/4.fc14/data/logs/x86_64/build.log
http://kojipkgs.fedoraproject.org/packages/compizconfig-backend-gconf/0.9.2.2/0.1.git86d949fad4.fc15/data/logs/x86_64/build.log

Comment 1 Adam Williamson 2011-01-20 23:24:19 UTC
hum, some of the commands get them, some don't...I'll look into it.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 2 Matěj Cepl 2011-01-21 16:39:36 UTC
This bug has been triaged

Comment 3 Adam Williamson 2011-01-24 02:09:25 UTC
so, it turns out this is wider - actually compiz itself builds without cflags, and the same for all compiz stuff that uses cmake.

it was due to a bug in a cmake file that compiz itself and all dependent bits include, which set CMAKE_C_FLAGS without including $CMAKE_C_FLAGS to keep whatever flags were previously set, so it overrode any you passed in.

I'm fixing this in compiz -11 and will then rebuild all the other packages, and they should then pick up the cflags correctly. I've sent the patch upstream to Sam. Thanks for the catch!

Comment 4 Adam Williamson 2011-01-24 04:25:20 UTC
okay, this should be fixed now: I've rebuilt all compiz cmake bits (I think) and checked the cflags were correctly used. I also checked the debuginfo for backend-gconf is there. thanks again for the report.