Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 704820

Summary: grub2 1.99-0.1 not built with $RPM_OPT_FLAGS, %changelog entry missing,
Product: [Fedora] Fedora Reporter: Ville Skyttä <ville.skytta>
Component: grub2Assignee: Peter Jones <pjones>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: dennis, elad, lkundrak, mads, pjones, sgrubb
Target Milestone: ---Keywords: Patch, Regression, Reopened
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: grub2-1.99-13.fc16 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-12-30 22:55:50 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 496968    
Attachments:
Description Flags
Build with $RPM_OPT_FLAGS none

Description Ville Skyttä 2011-05-15 10:03:59 UTC
Created attachment 498987 [details]
Build with $RPM_OPT_FLAGS

grub2 1.99-0.1 is not built with $RPM_OPT_FLAGS due to a sed error,
http://kojipkgs.fedoraproject.org/packages/grub2/1.99/0.1.fc16/data/logs/x86_64/build.log

++ sed -e s/-fstack-protector//g -e s/--param=ssp-buffer-size=4//g -e s/-mregparm=3/-mregparm=4//g -e s/-fasynchronous-unwind-tables//g
sed: -e expression #3, char 27: unknown option to `s'

There's one slash too many in "s/-mregparm=3/-mregparm=4//g".  Fix attached, and CFLAGS setting moved to before %configure so any errors in it will break the build instead of failing semi-silently.  However applying this patch will cause the build to fail at least for some reasons (maybe there's still something in optflags that needs to be filtered out).  1.98-3 did not have this problem, and it was built with full $RPM_OPT_FLAGS.


Two other unrelated issues that should be fixed:

%changelog entries are missing for > 1.98-4.

The release tag is not compliant to packaging guidelines, it should be
0.X.rc1%{?dist} instead of just 0.x%{?dist}.

Comment 1 Elad Alfassa 2011-09-01 16:44:58 UTC
Fixed in rawhide, grub2-1.99-1.fc17

F16 build coming soon.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 2 Ville Skyttä 2011-09-03 07:39:40 UTC
(In reply to comment #1)
> Fixed in rawhide, grub2-1.99-1.fc17

It is not fixed, the sed error is still there (also in 1.99-4.16) and $RPM_OPT_FLAGS are not being used:

http://kojipkgs.fedoraproject.org/packages/grub2/1.99/1.fc17/data/logs/x86_64/build.log

++ sed -e s/-fstack-protector//g -e s/--param=ssp-buffer-size=4//g -e s/-mregparm=3/-mregparm=4//g -e s/-fexceptions//g -e s/-fasynchronous-unwind-tables//g
sed: -e expression #3, char 27: unknown option to `s'

Comment 3 Mads Kiilerich 2011-09-06 19:04:46 UTC
*** Bug 731111 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Admin XMLRPC Client 2011-09-16 19:08:04 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 5 Fedora Update System 2011-12-10 06:09:08 UTC
grub2-1.99-13.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/grub2-1.99-13.fc16

Comment 6 Fedora Update System 2011-12-11 21:53:38 UTC
Package grub2-1.99-13.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing grub2-1.99-13.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-16975/grub2-1.99-13.fc16
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2011-12-30 22:55:50 UTC
grub2-1.99-13.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.