Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 732800

Summary: php-libvirt-debuginfo 0.4.4-1 is empty, *.so unstripped
Product: [Fedora] Fedora Reporter: Ville Skytt√§ <ville.skytta>
Component: php-libvirtAssignee: Michal Novotny <minovotn>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: areis, minovotn, virt-maint
Target Milestone: ---Keywords: Patch
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: php-libvirt-0.4.4-2.fc16 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-09-07 00:03:38 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 496968    

Description Ville Skyttä 2011-08-23 16:45:51 UTC
php-libvirt-debuginfo 0.4.4-1 is empty and the *.so unstripped because the *.so is not installed with executable perms; it needs to be executable in order for rpmbuild's debuginfo stuff to do its job.

Fix:

--- a/php-libvirt.spec
+++ b/php-libvirt.spec
@@ -68,2 +68,3 @@ rm -rf %{buildroot}
 make install DESTDIR=%{buildroot}
+chmod +x %{buildroot}%{php_extdir}/php-libvirt.so
 

By the way, it would have been easy to catch this problem with rpmlint...

Comment 1 Michal Novotny 2011-08-24 07:43:08 UTC
(In reply to comment #0)
> php-libvirt-debuginfo 0.4.4-1 is empty and the *.so unstripped because the *.so
> is not installed with executable perms; it needs to be executable in order for
> rpmbuild's debuginfo stuff to do its job.
> 
> Fix:
> 
> --- a/php-libvirt.spec
> +++ b/php-libvirt.spec
> @@ -68,2 +68,3 @@ rm -rf %{buildroot}
>  make install DESTDIR=%{buildroot}
> +chmod +x %{buildroot}%{php_extdir}/php-libvirt.so
> 
> 
> By the way, it would have been easy to catch this problem with rpmlint...

Thanks for the patch, Ville. I'm applying it to the git tree right now ;-)

Thanks again,
Michal

Comment 2 Fedora Update System 2011-08-24 07:56:39 UTC
php-libvirt-0.4.4-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/php-libvirt-0.4.4-2.fc14

Comment 3 Fedora Update System 2011-08-24 07:59:20 UTC
php-libvirt-0.4.4-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/php-libvirt-0.4.4-2.fc15

Comment 4 Fedora Update System 2011-08-24 08:01:24 UTC
php-libvirt-0.4.4-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/php-libvirt-0.4.4-2.fc16

Comment 5 Fedora Update System 2011-08-24 22:45:37 UTC
Package php-libvirt-0.4.4-2.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing php-libvirt-0.4.4-2.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/php-libvirt-0.4.4-2.fc16
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2011-09-07 00:03:33 UTC
php-libvirt-0.4.4-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2011-09-07 00:22:08 UTC
php-libvirt-0.4.4-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2011-09-07 03:23:18 UTC
php-libvirt-0.4.4-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.