Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 824046

Summary: Incompatible with mcollective 2.0.0
Product: [Fedora] Fedora EPEL Reporter: Justin Brown <justin.brown1.1>
Component: rubygem-stompAssignee: Michael Stahnke <mastahnke>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: unspecified    
Version: el6CC: mastahnke, steve.traylen
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-11-29 18:04:38 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Justin Brown 2012-05-22 15:54:43 UTC
Description of problem:

rubygem-stomp is a dependency of mcollective. With mcollective 2.0.0 (current in EPEL), stomp+ssl connectors require >=1.2.0 (current is 1.2.2) of rubygem-stomp.

MCollective will install and start (without a stomp+ssl connector) fine. There are no problems. If a stomp+ssl connector is configured, MCollective refuses to start and throws errors.

It would be helpful if rubygem-stomp could be upgraded to 1.2.2.

Thanks,

Justin

Comment 1 Steve Traylen 2012-05-22 17:16:07 UTC
Looking at the changelog:

https://github.com/stompgem/stomp/blob/master/CHANGELOG.rdoc

its seems to be mostly important bug fixes plus the addition on stomp 1.1
support but 1.0 support is still there.

I'd like to see this to.

I just verified that the 1.2.2 builds okay with out modification beyond
the obvious to the .spec file in el5 and fc16.

Comment 2 Michael Stahnke 2012-05-28 17:45:44 UTC
I'm putting 1.2.2 into Fedora today.  I'll them check and make sure it's all ok before putting it in EPEL. (I work at Puppet Labs, so I am very interested in ensuring mcollective and friends work well with this on EL)

Comment 3 Fedora Update System 2012-05-28 17:47:50 UTC
rubygem-stomp-1.2.2-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/rubygem-stomp-1.2.2-1.fc17

Comment 4 Fedora Update System 2012-07-02 22:32:53 UTC
rubygem-stomp-1.2.2-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 5 Steve Traylen 2012-09-14 13:11:23 UTC
And el?

Comment 6 Fedora Update System 2012-11-05 05:31:23 UTC
rubygem-stomp-1.2.2-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/rubygem-stomp-1.2.2-1.el5

Comment 7 Fedora Update System 2012-11-05 05:31:38 UTC
rubygem-stomp-1.2.2-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/rubygem-stomp-1.2.2-1.el6

Comment 8 Fedora Update System 2012-11-29 18:04:39 UTC
rubygem-stomp-1.2.2-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2012-11-29 18:06:41 UTC
rubygem-stomp-1.2.2-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.