Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 870548

Summary: Firefox armhf runs at small fraction of speed of Debian equivilent
Product: [Fedora] Fedora Reporter: shawnlandden
Component: firefoxAssignee: Martin Stransky <stransky>
Status: CLOSED CURRENTRELEASE QA Contact: Martin Stransky <stransky>
Severity: high Docs Contact:
Priority: unspecified    
Version: 18CC: dan, gecko-bugs-nobody, pbrobinson, stransky
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-01-09 10:22:14 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 245418    

Description shawnlandden 2012-10-26 19:57:35 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
run the v8 benchmark on armhf firefox

http://v8.googlecode.com/svn/data/benchmarks/v7/run.html

Fedora: 26
Debian experimental (ff 16): 366

Expected results:

similar results on same hardware and same version of firefox

Additional info:

this is because fedora uses --disable-methodjit and --disable-tracejit, the JIT works on all armhf hardware, and should be enabled, debian only disables the jit for armel (armv4t+)

Comment 1 Martin Stransky 2012-10-31 12:29:07 UTC
I wonder how is this bug related to security?

Comment 2 Tomas Hoger 2012-10-31 13:10:49 UTC
(In reply to comment #1)
> I wonder how is this bug related to security?

You made it non-public / security when you assigned it to yourself.  I'm reverting those changes.

Comment 3 Peter Robinson 2013-01-09 10:22:14 UTC
This is fixed in xulrunner-17.0.1-3 and later for F-17+ for armv7 platforms