Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 889554

Summary: exempi 2.2.0-4 not built with $RPM_*_FLAGS
Product: [Fedora] Fedora Reporter: Ville Skyttä <ville.skytta>
Component: exempiAssignee: Stanislav Ochotnicky <sochotni>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 18CC: dakingun, sochotni
Target Milestone: ---Keywords: Patch, Regression
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-02-01 17:20:25 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 496968    
Attachments:
Description Flags
Fix mentioned issues none

Description Ville Skyttä 2012-12-21 17:34:37 UTC
Created attachment 667315 [details]
Fix mentioned issues

http://kojipkgs.fedoraproject.org//packages/exempi/2.2.0/4.fc19/data/logs/x86_64/build.log

The changes made in 2.2.0-4 result in $RPM_OPT_FLAGS not being used, fix attached. While at it, use $RPM_LD_FLAGS too, and make the build verbose so it'll be easier to see what exactly was done.

Comment 1 Stanislav Ochotnicky 2013-01-02 09:59:53 UTC
Bah, I committed wrong version actually. It is enough to change CPPFLAGS only and thus no overwriting of RPM_OPT_FLAGS would happen

Comment 2 Fedora Update System 2013-01-02 11:57:52 UTC
exempi-2.2.0-5.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/exempi-2.2.0-5.fc18

Comment 3 Ville Skyttä 2013-01-02 15:29:14 UTC
(In reply to comment #1)
> It is enough to change CPPFLAGS
> only and thus no overwriting of RPM_OPT_FLAGS would happen

Looks like the bit that adds $RPM_LD_FLAGS to LDFLAGS is still missing from 2.2.0-5.fc18, see patch in comment 1. I wonder if things wouldn't work just fine if the whole LDFLAGS=... arg to %configure was just simply dropped; without taking a closer look -L%{_libdir} sounds superfluous.

Comment 4 Fedora Update System 2013-01-02 20:19:08 UTC
Package exempi-2.2.0-5.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing exempi-2.2.0-5.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-0071/exempi-2.2.0-5.fc18
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2013-02-01 17:20:27 UTC
exempi-2.2.0-5.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2013-02-04 10:05:35 UTC
exempi-2.2.0-6.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/exempi-2.2.0-6.fc18

Comment 7 Stanislav Ochotnicky 2013-02-04 10:06:36 UTC
(In reply to comment #3)
> (In reply to comment #1)
> > It is enough to change CPPFLAGS
> > only and thus no overwriting of RPM_OPT_FLAGS would happen
> 
> Looks like the bit that adds $RPM_LD_FLAGS to LDFLAGS is still missing from
> 2.2.0-5.fc18, see patch in comment 1. I wonder if things wouldn't work just
> fine if the whole LDFLAGS=... arg to %configure was just simply dropped;
> without taking a closer look -L%{_libdir} sounds superfluous.

You were right of course, I just wanted to get the other bugfix into stable first. Doing a respin with hopefully correct flags this time

Comment 8 Fedora Update System 2013-02-20 03:57:16 UTC
exempi-2.2.0-6.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.