Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 925591

Summary: insight: Does not support aarch64 in f19 and rawhide
Product: [Fedora] Fedora Reporter: Dennis Gilmore <dennis>
Component: insightAssignee: Patrick Monnerat <patrick>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: patrick, pbrobinson
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-09-29 17:34:41 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 922257    

Description Dennis Gilmore 2013-03-23 00:47:41 UTC
Support for the ARM 64 bit CPU architecture (aarch64) was introduced in 
autoconf 2.69.  insight appears to use an earlier version of 
autoconf, preventing its being built.  This can be fixed in of three ways (In order of preference):

1. Work with upstream to migrate the package to autoconf 2.69.

2. Rerun autoconf or autoreconf in %prep or %build prior to running 
configure.

3. Apply the patch at http://ausil.fedorapeople.org/aarch64/insight/insight-aarch64.patch
which updates config.guess and config.sub to recognize aarch64.

Comment 1 Patrick Monnerat 2013-05-07 14:01:03 UTC
Autoreconf is already called for this package (7.4.50-7.20120403cvs).

In addition, I'm not sure this architecture will be properly supported by this program.

Since I do not have access to dev+test environment for this platform (and not much time and interest in it, I have to admit), I suggest you submit patches that do not break compatibility with the primary architectures.
Please confirm or close bug. Thanks.

Comment 2 Dennis Gilmore 2014-06-23 15:29:15 UTC
detection was not perfect. the patches would not have broken primary arches if autoreconf is already called it is sufficient.

Comment 3 Peter Robinson 2014-06-24 10:25:48 UTC
This is still and issue:

checking for cos in -lm... yes
*** BFD does not support target aarch64-redhat-linux-gnu.
*** Look in bfd/config.bfd for supported targets.
Makefile:2386: recipe for target 'configure-bfd' failed
make[1]: Leaving directory '/builddir/build/BUILD/insight-7.4.50'
make[1]: *** [configure-bfd] Error 1

Comment 4 Patrick Monnerat 2014-08-28 12:37:58 UTC
A new snapshot has been packaged. Currently in rawhide anf F21-testing.
insight-7.8.50-1.20140827git.*.rpm
Please recheck and comment. Thanks.

Comment 5 Fedora Update System 2014-08-28 12:40:31 UTC
insight-7.8.50-1.20140827git.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/insight-7.8.50-1.20140827git.fc21

Comment 6 Fedora Update System 2014-09-23 04:36:35 UTC
insight-7.8.50-1.20140827git.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Peter Robinson 2014-09-29 17:34:41 UTC
Confirmed this is now built on aarch64