Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 926309

Summary: paps: Does not support aarch64 in f19 and rawhide
Product: [Fedora] Fedora Reporter: Dennis Gilmore <dennis>
Component: papsAssignee: Akira TAGOH <tagoh>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: i18n-bugs, tagoh
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-05-03 02:43:45 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 922257    

Description Dennis Gilmore 2013-03-23 15:41:33 UTC
Support for the ARM 64 bit CPU architecture (aarch64) was introduced in 
autoconf 2.69.  paps appears to use an earlier version of 
autoconf, preventing its being built.  This can be fixed in of three ways (In order of preference):

1. Work with upstream to migrate the package to autoconf 2.69.

2. Rerun autoconf or autoreconf in %prep or %build prior to running 
configure.

3. Apply the patch at http://ausil.fedorapeople.org/aarch64/paps/paps-aarch64.patch
which updates config.guess and config.sub to recognize aarch64.

Comment 1 Akira TAGOH 2013-03-28 03:18:11 UTC
it does run autoreconf in %prep already. assuming that you've rebuilt this package and file this due to some fail though, what was wrong then?

Comment 2 Akira TAGOH 2013-04-18 10:14:56 UTC
I'm not quite sure if it does help but I updated it with -f -i.

Comment 3 Fedora Update System 2013-04-18 10:25:51 UTC
paps-0.6.8-25.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/paps-0.6.8-25.fc19

Comment 4 Fedora Update System 2013-04-18 17:27:27 UTC
Package paps-0.6.8-25.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing paps-0.6.8-25.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-5995/paps-0.6.8-25.fc19
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2013-05-03 02:43:48 UTC
paps-0.6.8-25.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.