Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 926684

Summary: up-imapproxy: Does not support aarch64 in f19 and rawhide
Product: [Fedora] Fedora Reporter: Dennis Gilmore <dennis>
Component: up-imapproxyAssignee: Chris Adams <linux>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: manuel.wolfshant, mjuszkie, rakesh.pandit
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: up-imapproxy-1.2.8-0.1.20130726svn14389.fc20 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-10-01 02:09:10 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 922257, 991858    

Description Dennis Gilmore 2013-03-23 16:29:14 UTC
Support for the ARM 64 bit CPU architecture (aarch64) was introduced in 
autoconf 2.69.  up-imapproxy appears to use an earlier version of 
autoconf, preventing its being built.  This can be fixed in of three ways (In order of preference):

1. Work with upstream to migrate the package to autoconf 2.69.

2. Rerun autoconf or autoreconf in %prep or %build prior to running 
configure.

3. Apply the patch at http://ausil.fedorapeople.org/aarch64/up-imapproxy/up-imapproxy-aarch64.patch
which updates config.guess and config.sub to recognize aarch64.

Comment 1 Fedora Admin XMLRPC Client 2013-08-08 02:59:51 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 2 Chris Adams 2013-08-09 01:14:04 UTC
So I've taken over the package, and am looking at cleaning up the bugs.  Upstream for this is pretty idle, so I don't know if option #1 would happen.

I tried running autoconf, and separately autoreconf, in %build before %configure, but that gave me configure scripts that errored out, so #2 looks out.

So, I guess I'll go with the patch, which does still apply cleanly.  How was it generated?  At some point down the road, if upstream does make changes that break the application of the patch, what do I do?

Comment 3 Chris Adams 2013-09-17 14:14:25 UTC
*** Bug 992843 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2013-09-17 15:25:46 UTC
up-imapproxy-1.2.8-0.1.20130726svn14389.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/up-imapproxy-1.2.8-0.1.20130726svn14389.fc20

Comment 5 Fedora Update System 2013-09-17 18:16:45 UTC
Package up-imapproxy-1.2.8-0.1.20130726svn14389.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing up-imapproxy-1.2.8-0.1.20130726svn14389.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-16968/up-imapproxy-1.2.8-0.1.20130726svn14389.fc20
then log in and leave karma (feedback).

Comment 6 Marcin Juszkiewicz 2013-09-18 10:12:17 UTC
Built fine for AArch64. 

Used Fedora 20 package on Fedora 19 as we did not moved to F20 yet.

added karma

Comment 7 Fedora Update System 2013-10-01 02:09:10 UTC
up-imapproxy-1.2.8-0.1.20130726svn14389.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.