Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 967954

Summary: zathura-ps 0.2.2 broken debuginfo
Product: [Fedora] Fedora Reporter: Ville Skyttä <ville.skytta>
Component: zathura-psAssignee: Petr Šabata <psabata>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: fdc, psabata
Target Milestone: ---Keywords: Regression
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: girara-0.1.6-2.fc19 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-06-08 03:42:39 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 496968    

Description Ville Skyttä 2013-05-28 16:15:46 UTC
zathura-ps-fix_install.patch was removed when updating to 0.2.2, but this causes the *.so be built again in %install, and that time without the -g flag, thus breaking debuginfo.

When fixing this, I'd suggest also adding VERBOSE=1 to %build's make invocation so more information about the build is output.

Also, there's no %changelog entry for 0.2.2-1.

Comment 1 Ville Skyttä 2013-05-28 16:18:02 UTC
Looks like zathura-djvu 0.2.3-1 and zathura-pdf-poppler 0.2.3-1 have the same regression too.

Comment 2 François Cami 2013-05-28 16:32:50 UTC
Petr, could you fix these please?

Comment 3 Petr Šabata 2013-05-29 08:16:16 UTC
Oops!

Thanks for catching that.  I'll revert that change.

Comment 4 François Cami 2013-05-29 08:33:59 UTC
We could probably use sed like this:
sed -ie "s/install:\ all/install:\ /g" Makefile
instead of adding the patch again.

Comment 5 Fedora Update System 2013-05-29 15:37:22 UTC
girara-0.1.6-2.fc19,zathura-0.2.3-4.fc19,zathura-ps-0.2.2-2.fc19,zathura-pdf-poppler-0.2.3-2.fc19,zathura-djvu-0.2.3-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/girara-0.1.6-2.fc19,zathura-0.2.3-4.fc19,zathura-ps-0.2.2-2.fc19,zathura-pdf-poppler-0.2.3-2.fc19,zathura-djvu-0.2.3-2.fc19

Comment 6 Fedora Update System 2013-05-30 17:52:56 UTC
Package girara-0.1.6-2.fc19, zathura-0.2.3-4.fc19, zathura-ps-0.2.2-2.fc19, zathura-pdf-poppler-0.2.3-2.fc19, zathura-djvu-0.2.3-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing girara-0.1.6-2.fc19 zathura-0.2.3-4.fc19 zathura-ps-0.2.2-2.fc19 zathura-pdf-poppler-0.2.3-2.fc19 zathura-djvu-0.2.3-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-9651/girara-0.1.6-2.fc19,zathura-0.2.3-4.fc19,zathura-ps-0.2.2-2.fc19,zathura-pdf-poppler-0.2.3-2.fc19,zathura-djvu-0.2.3-2.fc19
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2013-06-08 03:42:39 UTC
girara-0.1.6-2.fc19, zathura-0.2.3-4.fc19, zathura-ps-0.2.2-2.fc19, zathura-pdf-poppler-0.2.3-2.fc19, zathura-djvu-0.2.3-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.