Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 969388

Summary: RFE: Provide a system-wide configuration directory
Product: [Fedora] Fedora Reporter: Lukas Brabec <lbrabec>
Component: firefoxAssignee: Martin Stransky <stransky>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: awilliam, gecko-bugs-nobody, kparal, lbrabec, stransky
Target Milestone: ---Keywords: FutureFeature
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: firefox-45.0.1-4.fc24 Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-04-02 16:41:42 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Attachments:
Description Flags
current (ugly) way of configuration none

Description Lukas Brabec 2013-05-31 10:51:23 UTC
Created attachment 755229 [details]
current (ugly) way of configuration

Fedora Test Day CDs provides pre-configured Firefox. This configuration is done in kickstart script and is not very pleasing. We need to unzip omni.ja, edit two files and zip it back. Moreover, omni.ja is somehow "Firefox optimized" (read "zip is broken" since I found no deoptimizer in Firefox 21), it is possible to unzip it, but updating the files doesn't work and the whole omni.ja has to be repacked.

It would be nice (not just for us, but also for any sytem administrator who e.g. wants to pre-configure Firefox on computers in lab or office) to have simple way to configure Firefox, such as configuration directory in /etc.

Comment 1 Kamil Páral 2013-05-31 10:57:21 UTC
To clarify, our major point is to set up a default homepage. I believe that is a task useful in general, e.g. in a school lab. We haven't found any better to way than to repack omni.ja during boot, and that is a very ugly approach. Maybe we have missed something?

We set these properties at the moment (an extract from attachment 755229 [details]):
browser.startup.homepage=https://fedoraproject.org/wiki/Test_Day:Current | http://webchat.freenode.net/?channels=fedora-test-day
pref("startup.homepage_welcome_url","");
pref("startup.homepage_override_url","");
pref("browser.rights.3.shown", true);

Comment 2 Martin Stransky 2013-06-03 12:16:55 UTC
There's such config location (/usr/lib(64)/firefox/defaults/preferences/) but it apparently does not work for the homepage.

Comment 3 Kamil Páral 2013-06-03 13:35:36 UTC
(In reply to Martin Stransky from comment #2)
> There's such config location (/usr/lib(64)/firefox/defaults/preferences/)
> but it apparently does not work for the homepage.

If that worked for homepage (and other options), that would be satisfactory for our Test Day Live image purposes. But it wouldn't help a sysadmin, because those files would be overwritten with each firefox update.

It seems that Firefox doesn't contain any configuration files at all:
$ rpm -qc firefox
$ 

I don't know how Firefox is packaged in Debian or other high-profile distributions (I can check if needed), but I just don't understand how sysadmins configure Firefox in Fedora?

Comment 4 Martin Stransky 2013-10-22 09:19:41 UTC
On 10/22/2013 01:06 AM, Adam Williamson wrote:> Hi, folks. Just curious about this. I'm fixing (I hope...) the test day
> kickstart's method of overriding the Firefox home page. At present it
> unpacks and re-packs omni.ja to set this and a few other preferences; as
> far as I can tell, it could quite easily not bother with that, and just
> dump a .js file in $libdir/firefox/browser/defaults/preferences
> containing the preferences it wants set, and that will override omni.ja
> just fine.
> 
> In figuring this out, I came across this blog:
> 
> http://mike.kaply.com/2013/05/06/dont-unpack-and-repack-omni-jar/
> 
> given that, I wondered if there's a reason we 'trojan' omni.ja with our
> distro-specific preferences in the firefox spec, rather than leaving it
> clean as per upstream and putting our preferences in an override file?
>

Comment 5 Adam Williamson 2013-10-22 16:13:05 UTC
As per above, I found in building an F20 live image that just putting the home page in a .js file in /usr/lib(64)/firefox/defaults/preferences/ works fine, now (and the way the kickstart currently does it no longer works). I suspect it's because of this change in the firefox spec:

http://pkgs.fedoraproject.org/cgit/firefox.git/commit/?id=ec429e944715fe7a0471a68f225b35e267fe8d67

i.e. our package now sets the default home page as a pref and not by hacking browserconfig.properties . I'll commit this change to spin-kickstarts.

Still, I guess this bug report can remain open, because the problem of a site admin not having anywhere good to override default properties still remains.

Comment 6 Jan Horak 2015-08-27 13:35:09 UTC
This might be related to: https://bugzilla.mozilla.org/show_bug.cgi?id=1170092

Comment 7 Fedora Update System 2016-03-31 15:01:09 UTC
firefox-45.0.1-4.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-eae761f28d

Comment 8 Fedora Update System 2016-04-01 20:54:39 UTC
firefox-45.0.1-4.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-eae761f28d

Comment 9 Fedora Update System 2016-04-02 16:41:36 UTC
firefox-45.0.1-4.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Kamil Páral 2016-04-05 08:15:59 UTC
Hi Martin, how exactly is this fixed? I still see no /etc directory in the package:

$ rpm -ql firefox | grep /etc
$ rpm -q firefox
firefox-45.0.1-2.fc23.x86_64

Does it work in a different way? I don't see it in "man firefox".
Thanks.

Comment 11 Kamil Páral 2016-04-05 08:20:49 UTC
Doh, I misread the version number, sorry! Now I see it:

$ rpm -ql firefox | grep /etc
/etc/firefox/pref
$ rpm -q firefox
firefox-45.0.1-4.fc24.x86_64