Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 984720

Summary: device-mapper-persistent-data 0.2.1-1 broken debuginfo
Product: [Fedora] Fedora Reporter: Ville Skytt√§ <ville.skytta>
Component: device-mapper-persistent-dataAssignee: Heinz Mauelshagen <heinzm>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: agk, gmazyland, heinzm, lvm-team, msnitzer
Target Milestone: ---Keywords: Patch, Regression
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-07-16 11:39:00 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 496968    
Attachments:
Description Flags
Fix for mentioned issues none

Description Ville Skyttä 2013-07-15 19:43:22 UTC
Created attachment 773890 [details]
Fix for mentioned issues

device-mapper-persistent-data 0.2.1-1 has broken debuginfo due to binaries stripped too early. The build also hides compiler command line and overrides $RPM_OPT_FLAGS with -O8. Fix for all these is attached, let me know if you'd like me to push and build this for devel.

Comment 1 Heinz Mauelshagen 2013-07-16 11:19:13 UTC
Thanks for spotting.
I'll build it...

Comment 2 Heinz Mauelshagen 2013-07-16 11:39:00 UTC
Built into rawhide...