Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 994982

Summary: xxdiff-4.0 is available
Product: [Fedora] Fedora Reporter: Upstream Release Monitoring <upstream-release-monitoring>
Component: xxdiffAssignee: Russell Cattelan <cattelan>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: cattelan, cattelan, chemobejk, i
Target Milestone: ---Keywords: FutureFeature, Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: xxdiff-4.0b1.20150712hg30158cd-1.fc23 xxdiff-4.0b1.20150712hg30158cd-1.fc22 Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-01-08 20:53:39 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Attachments:
Description Flags
SPEC file for xxdiff 4.0b1 none

Description Upstream Release Monitoring 2013-08-08 10:38:26 UTC
Latest upstream release: 4.0
Current version/release in Fedora Rawhide: 3.2-20.fc20
URL: http://sourceforge.net/api/file/index/project-name/xxdiff/mtime/desc/limit/100/rss

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring

Comment 1 Christopher Meng 2014-07-23 09:46:04 UTC
*** Bug 998969 has been marked as a duplicate of this bug. ***

Comment 2 Stefan Becker 2015-12-14 19:32:28 UTC
Created attachment 1105661 [details]
SPEC file for xxdiff 4.0b1

I downloaded the tip from the Mercurial repo and compiled it on F23.

I also triggered a scratch build for rawhide: http://koji.fedoraproject.org/koji/taskinfo?taskID=12188062

This removes the dependency on qt3. What can we do to move this forward?

Comment 3 Russell Cattelan 2015-12-15 00:37:19 UTC
Updated the specfile in git.

The next round of builds should pick it up.

Thanks for updating it.

Comment 4 Stefan Becker 2015-12-15 03:00:24 UTC
Can we also fast-forward the F23 and F22 branches to git HEAD and generate an update for them?

Comment 5 Stefan Becker 2015-12-17 15:48:18 UTC
Can you please run "fedpkg update" on both F22 & F23 branches? I tried but I do not have the rights to create bodhi updates for xxdiff.

Comment 6 Russell Cattelan 2015-12-17 23:41:47 UTC
f22 and f23 branches have been updated as well.

Builds passed

Comment 7 Stefan Becker 2015-12-18 05:17:41 UTC
Please push the F22 & F23 updates to bodhi so that users can start testing them.

Comment 8 Fedora Update System 2015-12-23 00:50:13 UTC
xxdiff-4.0b1.20150712hg30158cd-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15ff952fed

Comment 9 Fedora Update System 2015-12-23 00:51:00 UTC
xxdiff-4.0b1.20150712hg30158cd-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-82b85c4b29

Comment 10 Fedora Update System 2015-12-25 01:58:27 UTC
xxdiff-4.0b1.20150712hg30158cd-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-82b85c4b29

Comment 11 Fedora Update System 2015-12-30 20:57:48 UTC
xxdiff-4.0b1.20150712hg30158cd-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15ff952fed

Comment 12 Fedora Update System 2016-01-08 20:53:36 UTC
xxdiff-4.0b1.20150712hg30158cd-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2016-01-09 02:20:44 UTC
xxdiff-4.0b1.20150712hg30158cd-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.